Mailinglist Archive: opensuse-security-announce (15 mails)

< Previous Next >
[security-announce] SUSE-SU-2011:1185-1: important: Security update for Novell XTier framework
SUSE Security Update: Security update for Novell XTier framework
______________________________________________________________________________

Announcement ID: SUSE-SU-2011:1185-1
Rating: important
References: #585440
Cross-References: CVE-2011-1710
Affected Products:
SUSE Linux Enterprise Desktop 11 SP1
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:


Several user supplied header length variables for the HTTP
server component in the Novell XTier framework were not
size limited, allowing integer overflow attacks to crash
the service or potentially execute code. (CVE-2011-1710)

Security Issue reference:

* CVE-2011-1710
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-1710
>


Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Desktop 11 SP1:

zypper in -t patch sledsp1-novell-novfsd-5198

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Desktop 11 SP1 (i586 x86_64):

novell-novfsd-3.0.0-0.11.1
novell-xtier-base-3.1.8-0.7.1
novell-xtier-core-3.1.8-0.7.1
novell-xtier-xplat-3.1.8-0.7.1


References:

http://support.novell.com/security/cve/CVE-2011-1710.html
https://bugzilla.novell.com/585440

http://download.novell.com/patch/finder/?keywords=b8833ce91ca8c8d2a478a8a32a2e2efb

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages