Mailinglist Archive: opensuse-security-announce (20 mails)

< Previous Next >
[security-announce] openSUSE-SU-2011:0693-1: important: subversion security udpate
openSUSE Security Update: subversion security udpate
______________________________________________________________________________

Announcement ID: openSUSE-SU-2011:0693-1
Rating: important
References: #676949 #688968 #698205
Cross-References: CVE-2011-0715 CVE-2011-1752 CVE-2011-1783
CVE-2011-1921
Affected Products:
openSUSE 11.3
______________________________________________________________________________

An update that fixes four vulnerabilities is now available.

Description:

- CVE-2011-1752: The mod_dav_svn Apache HTTPD server
module can be crashed though when asked to deliver
baselined WebDAV resources.
- CVE-2011-1783: The mod_dav_svn Apache HTTPD server module
can trigger a loop which consumes all available memory on
the system.
- CVE-2011-1921: The mod_dav_svn Apache HTTPD server module
may leak to remote users the file contents of files
configured to be unreadable by those users.
- CVE-2011-0715: Remote attackers could crash an svn server
by causing a NULL deref


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.3:

zypper in -t patch libsvn_auth_gnome_keyring-1-0-4689

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 11.3 (i586 x86_64):

libsvn_auth_gnome_keyring-1-0-1.6.9-4.7.1
libsvn_auth_kwallet-1-0-1.6.9-4.7.1
subversion-1.6.9-4.7.1
subversion-devel-1.6.9-4.7.1
subversion-perl-1.6.9-4.7.1
subversion-python-1.6.9-4.7.1
subversion-ruby-1.6.9-4.7.1
subversion-server-1.6.9-4.7.1
subversion-tools-1.6.9-4.7.1


References:

http://support.novell.com/security/cve/CVE-2011-0715.html
http://support.novell.com/security/cve/CVE-2011-1752.html
http://support.novell.com/security/cve/CVE-2011-1783.html
http://support.novell.com/security/cve/CVE-2011-1921.html
https://bugzilla.novell.com/676949
https://bugzilla.novell.com/688968
https://bugzilla.novell.com/698205

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages