Mailinglist Archive: opensuse-ruby (11 mails)

< Previous Next >
Re: [opensuse-ruby] How to run current versions of ruby on Leap
On Tue, 27 Jun 2017 16:13:48 +0200
Cornelius Schumacher <cschum@xxxxxxx> wrote:

I tried to find some documentation about what our recommended way of running
a
recent version of Ruby on Leap is. Leap comes with 2.1 which is not supported
by upstream anymore. There are more recent versions available in the build
service, but they don't install as `ruby`, so most tooling doesn't work out
of
the box. I couldn't find any documentation about how this is supposed to be
done on Leap.

Most people actually seem to use and recommend rvm, which comes with its own
challenges.

What is our stance on this? Are there any pointers?


well, my suggestion do not try to change your system ruby to newer one,
otherwise YaST start failing misserably, as it is built against system one. So
I really suggest rvm or rbenv. I see that someone try update-alternatives, but
then YaST failing. ( it works with rvm or rbenv as yast explicitelly unset its
ENV to force it to use system ruby )

Josef
--
To unsubscribe, e-mail: opensuse-ruby+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-ruby+owner@xxxxxxxxxxxx

< Previous Next >
List Navigation