Mailinglist Archive: opensuse-ruby (22 mails)

< Previous Next >
[opensuse-ruby] rubygem-pygments.rb: Failing dependency /usr/bin/lasso9
  • From: Johannes Kastl <mail@xxxxxxxxxx>
  • Date: Wed, 12 Nov 2014 18:41:55 +0100
  • Message-id: <m40653$1ck$1@ger.gmane.org>
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hi,

during my adventures to build jekyll on the OBS I found one
dependency, that I can't satisfy:

sudo zypper in ruby2.1-rubygem-pygments.rb Loading repository
data... Reading installed packages... Resolving package
dependencies...

Problem: nothing provides /usr/bin/lasso9 needed by
ruby2.1-rubygem-pygments.rb-0.6.0-3.1.x86_64 Solution 1: do not
install ruby2.1-rubygem-pygments.rb-0.6.0-3.1.x86_64 Solution 2:
break ruby2.1-rubygem-pygments.rb-0.6.0-3.1.x86_64 by ignoring some
of its dependencies

Choose from above solutions by number or cancel [1/2/c] (c):

The only gem I found that is called something with lasso is built, but
does not provide /usr/bin/lasso9.

I also tried to install pygments.rb from d:l:r:e, but also no solution.

I found one spec from fedora, where this is excluded:
%global __requires_exclude ^/usr/bin/lasso9$

I'll try and see if this works, but I find it ugly. And I wonder why
this has not been needed before, the package has not been created today...

Any hints will be highly appreciated!

Regards,
Johannes
- --
They that can give up essential liberty to obtain a little temporary
safety deserve neither liberty nor safety.
(Benjamin Franklin, 1759)
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1
Comment: Using GnuPG with SeaMonkey - http://www.enigmail.net/

iEYEARECAAYFAlRjm+IACgkQzi3gQ/xETbKi1ACfd6pvba2flGU5Se3ijTiaAfEC
p30AoIbDZofWrY8TVJntxdVLJU/PixoJ
=lY9a
-----END PGP SIGNATURE-----

--
To unsubscribe, e-mail: opensuse-ruby+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-ruby+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups