Mailinglist Archive: opensuse-ruby (16 mails)

< Previous Next >
Re: [opensuse-ruby] Funny thing with rubygem dependencies
On Wed, 21 May 2014 19:52:00 +0200
Johannes Kastl <mail@xxxxxxxxxx> wrote:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hi everyone,

I have a funny issue with a dependency from a rubygem, depending on
another rubygem:

$ LANG=POSIX sudo zypper in rubygem-jekyll Loading repository
data... Reading installed packages... Resolving package
dependencies...

Problem: nothing provides rubygem(2.0.0:liquid:2.5) >= 2.5.5 needed
by rubygem-jekyll-2.0.3-3.2.x86_64 Solution 1: do not install
rubygem-jekyll-2.0.3-3.2.x86_64 Solution 2: break
rubygem-jekyll-2.0.3-3.2.x86_64 by ignoring some of its
dependencies

Choose from above solutions by number or cancel [1/2/c] (c): ^C $
LANG=POSIX sudo zypper in rubygem-liquid Loading repository
data... Reading installed packages... Resolving package
dependencies...

The following NEW package is going to be installed: rubygem-liquid


1 new package to install. Overall download size: 76.0 KiB. After
the operation, additional 116.3 KiB will be used. Continue? [y/n/?
shows all options] (y): ^C

So jekyll depends on liquid, and I can install liquid. liquid is
version 2.6.1, so it should satisfy jekyll's dependency on liquid
=2.5.5? Or am I missing something?

actually no, as require is
rubygem(2.0.0:liquid:2.5)

which means
ruby version 2.0.0, gem liquid and major version 2.5 and >= 2.5.5
means that any version with between 2.5.4 and 2.6.0 satisfy it.
It is our workaround for rubygem operator ~> which do what I describe
above. For details see
http://stackoverflow.com/questions/5170547/what-does-tilde-greater-than-mean-in-ruby-gem-dependencies

Josef

--
To unsubscribe, e-mail: opensuse-ruby+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-ruby+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References