Mailinglist Archive: opensuse-ruby (27 mails)

< Previous Next >
Re: [opensuse-ruby] the case of the two rubies
On Fri, Feb 07, 2014 at 08:28:38AM +0100, Stephan Kulow wrote:
Hi,

Now that Klaus' ruby merge is done, I switched the OBS project
to use it - as a test bed of a "product". It's plain impossible
to keep yast and update OBS on 13.1 ;(

Do you mean OBS as the build object, not subject?
https://build.opensuse.org/project/monitor/OBS:Server:2.5
I was quite confused before I understood that.

We have several things required by yast

libruby2.0.so.2.0 is required by yast2-ruby-bindings and libstorage-ruby
ruby(abi) == 2.0.0 is required by rubygem-ruby-dbus and rubygem-fast_gettext

FWIW, as the upstream for rubygem-ruby-dbus I can say that it works
with any Ruby version >= 1.9. I am not sure whether we should try
packaging some gems as independent on the Ruby version.
--
Martin Vidner, Cloud & Systems Management Team
http://en.opensuse.org/User:Mvidner

Kuracke oddeleni v restauraci je jako fekalni oddeleni v bazenu
< Previous Next >
List Navigation
References