Mailinglist Archive: opensuse-ruby (27 mails)

< Previous Next >
Re: [opensuse-ruby] the case of the two rubies
On Fri, 07 Feb 2014 08:28:38 +0100
Stephan Kulow <coolo@xxxxxxx> wrote:

Hi,

Now that Klaus' ruby merge is done, I switched the OBS project
to use it - as a test bed of a "product". It's plain impossible
to keep yast and update OBS on 13.1 ;(

We have several things required by yast

libruby2.0.so.2.0 is required by yast2-ruby-bindings and
libstorage-ruby ruby(abi) == 2.0.0 is required by rubygem-ruby-dbus
and rubygem-fast_gettext packages linking against ruby 2.1. The libruby2.0
problem will be gone
for future updates as we now have libruby2_1 as a special package, but
the ruby(abi) problem will stay and as I said before: making
/usr/bin/ruby an update-alternative is only a solution as long
as rubygem-fast_gettext isn't required by OBS with a different
ruby abi.


Yes,
yast bindings is built against ruby that is provided by given release
of opensuse and same for other C-bindings like libstorage. So if you
want base OBS product on 13.1 you should use ruby that is provided
there. And if you want it base on 13.2 then I hope it will have ruby
2.1. It is similar like with any other library or scripting language,
if distribution provide perl 5.10 and you need 5.11, then you need to
somehow bundle it and do work-arounds.

Josef

Greetings, Stephan


--
To unsubscribe, e-mail: opensuse-ruby+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-ruby+owner@xxxxxxxxxxxx

< Previous Next >
List Navigation
Follow Ups
References