Mailinglist Archive: opensuse-ruby (69 mails)

< Previous Next >
Re: [opensuse-ruby] A new packaging scheme for Ruby 2.1
On Wed, 22 Jan 2014 15:18:13 +0100
Klaus Kaempf <kkaempf@xxxxxxx> wrote:

* Martin Vidner <mvidner@xxxxxxx> [Jan 22. 2014 14:58]:
On Wed, Jan 22, 2014 at 01:23:25PM +0100, Klaus Kaempf wrote:
I'd like to generate the following packages for Ruby 2.1

1. ruby-2.1
This would provide binaries (ruby, irb, rake, gem, ...) and a
minimal set of documentation (changelog, readme, news, ...)

2. libruby2
This would only provide the libruby2.1.so.2.0.0 shared library

3. ruby-stdlib
This would provide the /usr/lib64/ruby/2.1.0/ directory tree.

Which use case needs 1+2+3 separated?

Just for smaller maintenance updates.

I think it is not enough value to do it. It is more confusing to users.
I think that if you want rid of multiversion there should be one "ruby"
package that contains the latest upstream stable version.


Plus a separate ruby-stdlib might help with a future
ruby-stdlib-as-gems approach.


Really? How? If upstread decide to move e.g. OpenURI to own gem how
this can help? all projects using OpenURI must be adapted or doesn't
work with next ruby version and next ruby or ruby-stdlib do not contain
it.

Josef

P.S. Thanks to write suggestion on mailing list before you start
implementing ;)

Klaus

--
To unsubscribe, e-mail: opensuse-ruby+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-ruby+owner@xxxxxxxxxxxx

< Previous Next >
List Navigation