Mailinglist Archive: opensuse-ruby (83 mails)

< Previous Next >
Re: [opensuse-ruby] Revised gem packaging
  • From: Adam Spiers <aspiers@xxxxxxxx>
  • Date: Wed, 7 Nov 2012 12:06:23 +0000
  • Message-id: <20121107120623.GY24068@pacific.linksys.moosehall>
Klaus Kaempf (kkaempf@xxxxxxx) wrote:
* Adam Spiers <aspiers@xxxxxxxx> [Nov 06. 2012 12:54]:
Stephan Kulow (coolo@xxxxxxx) wrote:
On 06.11.2012 09:54, Klaus Kaempf wrote:
* Stephan Kulow <coolo@xxxxxxx> [Nov 06. 2012 06:43]:

It's not a bug, it's a design limitation.

LOL

BTW: zypper doesn't like two
packages named rubygem-foo either.

Can you please be more specific here ?

zypper is supporting multiple versions of a package (i.e. the linux
kernel) for quite some time and I don't see issues with zypper and the
four versions of sblim-sfcb in systemsmanagement:wbem either.

Yeah, if you configure multiversion for kernels in zypp.conf - do you
want to change zypp.conf for all gems?

multiversion is not necessarily a requirement here. We are talking
about a single OBS project providing the *choice* of multiple versions
of a gem.

Right, thats the primary requirement.

However, from a developer POV, the ability to install multiple
versions of a single GEM is important when working with different
Ruby/Rails projects.

Right. Potentially even multiple versions of the same minor version,
e.g. 1.2.3 and 1.2.5. As I already mentioned[1], a '-1_2' Name suffix
does not allow this (and has several other disadvantages).

AFAICS, sblim-sfcb in systemsmanagement:wbem is an example
where multiversion would *not* be required, because e.g. 1.3.7 would
only ever be installed on SP1 machines, and 1.3.11 on SP2 machines.

Not quite. I build sblim-sfcb in multiple versions so I can upgrade it
on a e.g. SP1 machine without migrating it to SP2.

Ah, OK. Sounds like we agree about the need to support both use cases
though.

and then any product-oriented rpm could install the appropriate
multiversion policy / policies into /etc/zypp/multiversion.d/

Shouldn't multiversion be the default for zypper ?

Esp. since we put so much effort into shared library packaging with
the ability to install multiple versions in parallel ?

Hah - I'm guessing there is a good reason it's not the default, but I
have no idea what that is :)

[1] http://lists.opensuse.org/opensuse-ruby/2012-11/msg00039.html
--
To unsubscribe, e-mail: opensuse-ruby+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-ruby+owner@xxxxxxxxxxxx

< Previous Next >
List Navigation