Mailinglist Archive: opensuse-ruby (15 mails)

< Previous Next >
Re: [opensuse-ruby] Revised gem packaging
Am 25.10.2012 16:42, schrieb Adam Spiers:
No, these are limitations in rpm itself. As darix pointed out last
year, bundler's ~> operator cannot map straightforwardly into rpm
Requires expressions:

http://lists.opensuse.org/opensuse-ruby/2011-07/msg00000.html

Yeah, but that information is outdated - if you read the thread a year
later:
http://lists.opensuse.org/opensuse-ruby/2012-07/msg00025.html

So the policy we live is this: we package <gem> as rubygem-<gem>
and only add a version suffix only if something requires an old
version of <gem> (and then only to the old version) or if
<gem> is <rails> - for historical reasons :)

We didn't rename all gem_1_0 packages yet, but we're going there
whenever we update a package.

Greetings, Stephan

--
To unsubscribe, e-mail: opensuse-ruby+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-ruby+owner@xxxxxxxxxxxx

< Previous Next >
List Navigation