Mailinglist Archive: opensuse-ppc (48 mails)

< Previous Next >
Re: [suse-ppc] Over-ride MD5SUM errors during install
  • From: larrystotler@xxxxxxxxxxxx
  • Date: Fri, 27 Oct 2006 09:15:38 -0400
  • Message-id: <8C8C7E12124999F-F34-664@xxxxxxxxxxxxxxxxxxxxxxxxxxx>
-----Original Message-----
From: srglasoe@xxxxxxxxxxx
>What's the common denominator here? Do you have original SUSE CD/DVDs from

>the boxed sets and do they suffer these same errors? Are you using the same

>brand of blank CD/DVDs? Do the suspect CD/DVDs work sometimes but not
>others? Sounds like you have plenty of machines and CD/DVD drives to play
>with and troubleshoot the problem.

That's just it, it's NOT reproducable at all. I get different errors all the time. One package

may fail on one install, and then it will install just fine on the next. It doesn't matter what machine

I use or how I burn the discs. I have tried way too many combinations to get the same issue over and over

again. For example, on the Xeon system I was installing last night, I was using the new remastered CDs, and

if I clicked "ignore", instead of skipping the file, the installation just failed. And all it told me was

that the package wasn't on the medium because it failed the integrity check. Here's the line:

Err: 3:Package kdebase3-32bit-3.5.1-69.32 fails integrity check. Do you want to retry downloading it?

This is a new one on me. I usually got an error saying what MD5SUM it got and waht it was supposed to get.

I haven't had time to try installing on my B&W G3 to see if I will have the same problems on it.

A friend of mine says he's had so many problems getting the CDs to work since v9.2, that he downloads the whole tree

instead. I even tried installing on a PowerMac over the network from his tree and got MD5SUM errors in the beginning of

this year.......

>How's the power situation? Are you overloading circuits with too many
>machines and suffering mini-brownouts? Does the A/C or refrigerator cycling
>or the clothes washer/dryer affect your power?

Nope. I've even had the problem runnng through a UPS that was conditioning the line voltage.

>Since version 10.0 have you been downloading the ISOs and do they pass the
>checksum test of K3B before you burn them? That should produce a known good
>copy for installs.

The MD5SUM check is fine BEFORE I burn the CD. If I have K3B verify it, it fails. If I have the media

check verify it, it fails. It doesn't matter what burner I use or what speed or whatever.

Interestingly enough, I was finally able to finish the install last night if I ONLY let it do the basic

suggested KDE install. If I selected the addon media it didn't work. Further, it rebooted after the first

CD if I chose the basic install, but if I added packages, it went to the Add-on CD-1 instead of rebooting.

>I've had those errors during installs and restarting from the very beginning
>is not fun. Nothing like the problems you have though.

That's just it. I have been using SuSE for the x86 since v5.3. I only started having these problems with

the v10.0 Betas for the PPC, and I have had them since then. It doesn't ALWAYS happen. However, if I were

give someone a copy of these CDs and they would not install properly, that person would probably never

bother trying to install SuSE again. And I wouldn't blame them. I've been extremely disgusted with the way

that v10.1 was rolled out. They should have never tried to integrate libzipp and zen-updater in, what was it,

Beta 3 or 4? I have only managed to get v10.1 to update properly on 1 machine. This Thinkpad I am on right

now always tells me that there are no new updates. Doesn't matter how I try to get the updates to work. None

of the methods from openSuSE or elsewhere have worked on this machine. I've been a proud supporter of SuSE for

7 years, but there is NO WAY I would have bought a copy of v10.1 considering it's state. I even asked about

getting the CDs remastered and was told it wouldn't be done, and then they remastered them 2 months before

v10.2 is supposed to come out. I've had several friend who are fairly new to linux go back to v10.0 on their machines

because they couldn't get v10.1 to work right.

To all the guys like Olaf and everyone else that has helped me out, I'm not trying to knock you, but v10.1, IMHO,

has been nothing short of a disaster. The problems with the Old World machines was beyond your control and

the pactches to fix them(which I have still not gotten to work yet....:( ) were greatly appriciated. But, I feel

there needs to be some changes so that if any prospective newbie tries to install, they don't get mad and give up.


The root password should be asked for BEFORE starting the install. I don't know how many times I have had an instal

fail after the reboot after the first CD and then get a login prompt that is useless to me(I COULD fix it manually,

but lots of others can't). Even without my issues, if a power failure occurs, at least you can login to the system.

Allow an undocumented command line switch that will turn off the MD5SUM checking. Personally, I think it is a waste

of processing power, especially on older machines like my G3/266. I wouldn't install the CDs if I didn't trust where

they came from. I think it would speed up the installs on older slower machines by a noticable percent to say the

least. IMHO it's unneccessary.

The installer should be able to tell if a previous install has failed. At least add an option to the start where

it asks if it's an update or new installation for repair failed installation.

Again, sorry to vent.

Check Out the new free AIM(R) Mail -- 2 GB of storage and industry-leading spam and email virus protection.
< Previous Next >