Mailinglist Archive: opensuse-packaging (95 mails)

< Previous Next >
Re: [opensuse-packaging] rust 1.36 build unresolvable as no cargo >=1.35 for Leap 15.2 ARM and PowerPC
On 11/22/19 2:06 PM, Alberto Planas Dominguez wrote:
On Friday, November 22, 2019 1:58:35 PM CET Normand wrote:
For ARM and PowerPC, rust build failed (1) as stated above.
the available rpms on repos are version 1.32 (2)

There was no build failure for Factory that generated version 1.38 (3)

I think that the problem is that OBS cannot find 1.35 when try to compile
1.36. One way of solving it can be using the bcond rust_bootstrap via the
project config, that will use the included ARM binary to generate a new
compiler.


Thank you Alberto,
it seems to start the build in my home project, I am waiting for completion.
https://build.opensuse.org/package/show/home:michel_mno:branches:openSUSE:Leap:15.2/rust


--
Michel Normand

--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-packaging+owner@xxxxxxxxxxxx

< Previous Next >
List Navigation