Mailinglist Archive: opensuse-packaging (104 mails)

< Previous Next >
[opensuse-packaging] trac requires python-pygments, which cannot be found on oS Leap 15.0
Greetings,

when I try to install trac[0] on openSUSE Leap 15.0, I receive the
following error:
------------------------------ 8< ------------------------------
# zypper in --dry-run trac
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: nothing provides python-pygments needed by trac-1.2.2-lp150.1.2.noarch
Solution 1: do not install trac-1.2.2-lp150.1.2.noarch
Solution 2: break trac-1.2.2-lp150.1.2.noarch by ignoring some of its
dependencies

Choose from above solutions by number or cancel [1/2/c] (c):
------------------------------ >8 ------------------------------

This is strange, because python-pygments should be available from the
oS 15.0 base repo (as the spec[1] provides the exact spelling trac
requires[2]). However, when I use OBS to display the provides of the
built RPM, the provides is missing[3]. How come? Is this an OBS issue
or am I misunderstanding something? What can I do?


[0]: https://build.opensuse.org/package/show/devel%3Atools%3Ascm/trac
[1]:
https://build.opensuse.org/package/view_file/openSUSE:Leap:15.0/python-Pygments/python-Pygments.spec?expand=1
(line 37)
[2]:
https://build.opensuse.org/package/binary/devel:tools:scm/trac/openSUSE_Leap_15.0/x86_64/trac-1.2.3-lp150.1.1.noarch.rpm
[3]:
https://build.opensuse.org/package/binary/openSUSE:Leap:15.0/python-Pygments/standard/x86_64/python2-Pygments-2.2.0-lp150.2.7.noarch.rpm


--
Kind regards
Christopher 'm4z' Holm / 686f6c6d

"We must respect the other fellow's religion, but only in the sense
and to the extent that we respect his theory that his wife is
beautiful and his children smart." --H. L. Mencken
--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-packaging+owner@xxxxxxxxxxxx

< Previous Next >
List Navigation
Follow Ups