Mailinglist Archive: opensuse-packaging (116 mails)

< Previous Next >
Re: [opensuse-packaging] Help: Build fails on Leap Builds
On 12/28/2017 3:54 PM, Klaas Freitag wrote:
Hi,

can anybody help me to understand what is going wrong in
https://build.opensuse.org/package/show/home:ocfreitag:branches:KDE:Extra/owncloud-client
?

The Leap builds are failing because of a post build check complaining
about duplicates:
[ 174s] found conflict of owncloud-client-2.4.0-27.1.x86_64 with
owncloud-client-doc-2.4.0-27.1.x86_64:
[ 174s] - /usr/share/doc/packages/owncloud-client/html/advancedusage.html

It complains about all files in the doc subfolder called 'html' which
should be in the -doc subpackage, and only there. The main package
owncloud-client should only contain a few doc files like README and such.

In the Tumbleweed builds, this all works like expected, and the packages
contain the right doc files.

What is going on with the Leap builds?

Thx,

Klaas


Not related to issues you are facing, but please use %cmake and
%cmake_install macros ...

Cheers

Martin
--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-packaging+owner@xxxxxxxxxxxx

< Previous Next >
References