Mailinglist Archive: opensuse-packaging (127 mails)

< Previous Next >
[opensuse-packaging] alternative "Requires:" - how?

I want to provide a package, DokuWiki. This package requires PHP Version
5.6 or later.

To produce a package realizing this requirement, I tried

Requires: (php5 >= 5.6 or php7)

which I read on <> as a
way to do this.

But OBS told me that Requires: are not allowed to start with "(", so I
replaced it by

Requires: php5 >= 5.6 or php7

and now zypper tells me that "nothing provides or needed by
DokuWiki-2017.02.19e-9.1.noarch" :)

So, how can I set alternatives for "Requires:"?

Well, for this package I can set

Requires: php >= 5.6
Requires: mod_php_any >= 5.6

but is there a more general solution as described for rpm4 three years ago?



< Previous Next >