Mailinglist Archive: opensuse-packaging (74 mails)

< Previous Next >
Re: [opensuse-packaging] Basic question on ruby packaging and build ruby-dependent packages (chef)

On 04/29/2017 09:51 PM, Johannes Kastl wrote:
Hi Jordi,

On 28.04.17 15:48 Jordi Massaguer Pla wrote:
Is there any docu on how to bootstrap gem2rpm (I found the
variable in the spec, but no experiments worked so far)? Or how
to get started with ruby packaging and the whole prjconf voodoo?
You can find most of the documentation in here:
Jordi, no offence meant, I am grateful for your answer. But actually I
was hoping for something more than the link to the number one google
page when looking for "opensuse ruby packaging"...

Your question in particular, I think it can be resolved by
redefining some macros in your project. See for example:
Again, no offence meant. If you would have looked into my project you
would have found that I already copied over the prjconf from d:l:r and
d:l:r:backports. And tried to adapt it. That was why I was talking
about "prjconf voodoo"...

I don't remember building rubygems for a different ruby other than
the one in the official repos, but I guess redefining some of the
macros should do the trick.
Ahem. Allow me to ask my question again: Is there any documentation on
how to do that? On how and why to define and use gem2rpm_bootstrap
when building rubygem-gem2rpm? The Packaging_Ruby page does not even
mention it...

I think I understand roughly what the Macro parts (e.g. %ruby()) do.
But everything I tried with gem2rpm_bootstrap did not work. Setting it
in prjconf, setting it to bcond_with in the spec, ...

Please don't get me wrong, I'll appreciate all hints and tipps and
RTFM. But I feel kind of lost as I find no shred of information about
all the variables set in prjconf and in the packages, and how they all
relate to each other.

Hi, I am not aware of any more documentation.

I just took a quick look at your project configuration:

First of all, ruby2.2 is not building, thus there is no ruby2.2 at all for sle11*.

Second, in your project configuration you are setting the ruby version for sle11* with

%if 0%{?suse_version} == 1110

That is fine with what you want to do, but do not expect that to be applied for sle12, meaning you won't be using ruby2.2 for sle12.

You can find how to check for different suse versions in

I hope this helps


To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-packaging+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups