Mailinglist Archive: opensuse-packaging (132 mails)

< Previous Next >
Re: [opensuse-packaging] Conflicting gcc versions?
On Donnerstag, 5. Januar 2017, 13:22:44 CET wrote Marco Varlese:
On Thu, 2017-01-05 at 11:27 +0100, Adrian Schröter wrote:
On Donnerstag, 5. Januar 2017, 11:15:17 CET wrote Marco Varlese:

I have two packages (one linked to the other) to build on different
architectures and platforms.
In order to build the code for a specific platform I need a specific
gcc (v.6.0) but when the build kicks off for OpenSuse 42.2 I get the
error despite the fact that gcc6 is available on that distro.

unresolvable: conflict for provider of libgcc_s1 >= 6.1.1+r238085-1.12
needed by
gcc6 (provider libgcc_s1-gcc6 is conflicted by installed libgcc_s1)

I'd like to keep the two .spec files as aligned as possible (hence keeping
dependency in both of them) to avoid bugs introduced in one version of the
vs the other.

The build is successful for the Factory repos.

Is there a way to fix this problem (i.e. force OBS to use/install a
version of gcc) ? On an installed distro (42.2), this works fine by
one version of gcc rather than the other...

Yes, but there is only a way via the prjconf:

Preinstall: !libgcc_s1
Preinstall: libgcc_s1-gcc6
Thanks for the hint; however, this I think is a project wide setting so all
packages under my project will be affected, even other packages which
be. Do I get this right?

yes, right, but the newer libgcc_s1 should be fully backward compatible. So IMHO
the risk is really low.

A possible solution then would be to create a project containing only the
packages which I need to and separate others...?

IMHO we should modify our official project configuration of openSUSE to use

the newer libgcc_s1 always. We can maybe do this in :Update project at
I was wondering the same; if we have gcc6 available for 42.2 why OBS is still
(by default) building with the older compiler?

because it is still the default compile used in SLE and therefore all sources
are only QA'd with the older one.

Couldn't we have the most recent
one (available for a given distro) being the default compiler for OBS?

No, but IMHO the switch to the newer libgcc_s1 should be okay.
That way a package just needs to

BuildRequires: gcc >= 6.0

or alike to switch.



Adrian Schroeter
email: adrian@xxxxxxx

SUSE Linux GmbH, GF: Felix Imendörffer, Jane Smithard, Graham Norton, HRB 21284
(AG Nürnberg)

Maxfeldstraße 5
90409 Nürnberg

To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-packaging+owner@xxxxxxxxxxxx

< Previous Next >