Mailinglist Archive: opensuse-packaging (132 mails)

< Previous Next >
Re: [opensuse-packaging] Conflicting gcc versions?
On Thu, 5 Jan 2017, Adrian Schröter wrote:

On Donnerstag, 5. Januar 2017, 11:15:17 CET wrote Marco Varlese:

I have two packages (one linked to the other) to build on different
architectures and platforms.
In order to build the code for a specific platform I need a specific
version of
gcc (v.6.0) but when the build kicks off for OpenSuse 42.2 I get the
error despite the fact that gcc6 is available on that distro.

unresolvable: conflict for provider of libgcc_s1 >= 6.1.1+r238085-1.12
needed by
gcc6 (provider libgcc_s1-gcc6 is conflicted by installed libgcc_s1)

I'd like to keep the two .spec files as aligned as possible (hence keeping
dependency in both of them) to avoid bugs introduced in one version of the
vs the other.

The build is successful for the Factory repos.

Is there a way to fix this problem (i.e. force OBS to use/install a specific
version of gcc) ? On an installed distro (42.2), this works fine by
one version of gcc rather than the other...

Yes, but there is only a way via the prjconf:

Preinstall: !libgcc_s1
Preinstall: libgcc_s1-gcc6

IMHO we should modify our official project configuration of openSUSE to use
the newer libgcc_s1 always. We can maybe do this in :Update project at least?

Yeah, not sure why 42.2 doesn't mirror what SLE12 does here. I think I
remember that GCC 6 was taken into 42.2 "early" (before we actually
released the Toolchain module update), so it has probably been



Richard Biener <rguenther@xxxxxxx>
SUSE LINUX GmbH, GF: Felix Imendoerffer, Jane Smithard, Graham Norton, HRB
21284 (AG Nuernberg)
< Previous Next >
Follow Ups