Mailinglist Archive: opensuse-packaging (132 mails)

< Previous Next >
Re: [opensuse-packaging] Conflicting gcc versions?
On Donnerstag, 5. Januar 2017, 11:15:17 CET wrote Marco Varlese:
Hi,

I have two packages (one linked to the other) to build on different
architectures and platforms.
In order to build the code for a specific platform I need a specific version
of
gcc (v.6.0) but when the build kicks off for OpenSuse 42.2 I get the following
error despite the fact that gcc6 is available on that distro.

unresolvable: conflict for provider of libgcc_s1 >= 6.1.1+r238085-1.12 needed
by
gcc6 (provider libgcc_s1-gcc6 is conflicted by installed libgcc_s1)

I'd like to keep the two .spec files as aligned as possible (hence keeping the
dependency in both of them) to avoid bugs introduced in one version of the
file
vs the other.

The build is successful for the Factory repos.

Is there a way to fix this problem (i.e. force OBS to use/install a specific
version of gcc) ? On an installed distro (42.2), this works fine by installing
one version of gcc rather than the other...

Yes, but there is only a way via the prjconf:

Preinstall: !libgcc_s1
Preinstall: libgcc_s1-gcc6

IMHO we should modify our official project configuration of openSUSE to use
the newer libgcc_s1 always. We can maybe do this in :Update project at least?

Ludwig?

--

Adrian Schroeter
email: adrian@xxxxxxx

SUSE Linux GmbH, GF: Felix Imendörffer, Jane Smithard, Graham Norton, HRB 21284
(AG Nürnberg)

Maxfeldstraße 5
90409 Nürnberg
Germany


--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-packaging+owner@xxxxxxxxxxxx

< Previous Next >
References