Mailinglist Archive: opensuse-packaging (132 mails)

< Previous Next >
[opensuse-packaging] Conflicting gcc versions?
Hi,

I have two packages (one linked to the other) to build on different
architectures and platforms.
In order to build the code for a specific platform I need a specific version of
gcc (v.6.0) but when the build kicks off for OpenSuse 42.2 I get the following
error despite the fact that gcc6 is available on that distro.

unresolvable: conflict for provider of libgcc_s1 >= 6.1.1+r238085-1.12 needed by
gcc6 (provider libgcc_s1-gcc6 is conflicted by installed libgcc_s1)

I'd like to keep the two .spec files as aligned as possible (hence keeping the
dependency in both of them) to avoid bugs introduced in one version of the file
vs the other.

The build is successful for the Factory repos.

Is there a way to fix this problem (i.e. force OBS to use/install a specific
version of gcc) ? On an installed distro (42.2), this works fine by installing
one version of gcc rather than the other...


Thanks,
Marco
--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-packaging+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups