Mailinglist Archive: opensuse-packaging (129 mails)

< Previous Next >
Re: [opensuse-packaging] RPM require version range
On Mon, Jan 4, 2016 at 1:41 AM, Ferdinand Thiessen <f.thiessen@xxxxxx> wrote:
Hi,

How do I require a version range?
E.g. I need lua 5.2.x I tried:

BuildRequires: Lua(devel) >= 5.2, Lua(devel) < 5.3

But this will fail with a "Have choice" error, so rpm / buildservice
finds lua 5.1 and lua 5.2 for BuildRequire " Lua(devel) < 5.3". So it
does not combine the two statements.


I think you need a conflicts statement:

BuildRequires: Lua(devel) >= 5.2
Conflicts: Lua(devel) >= 5.3

Greg
--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-packaging+owner@xxxxxxxxxxxx

< Previous Next >
References