Mailinglist Archive: opensuse-packaging (129 mails)

< Previous Next >
Re: [opensuse-packaging] RPM require version range
On Monday 04 January 2016, 07:41:16 wrote Ferdinand Thiessen:
Hi,

How do I require a version range?
E.g. I need lua 5.2.x I tried:

BuildRequires: Lua(devel) >= 5.2, Lua(devel) < 5.3

But this will fail with a "Have choice" error, so rpm / buildservice
finds lua 5.1 and lua 5.2 for BuildRequire " Lua(devel) < 5.3". So it
does not combine the two statements.

I would go this way:

BuildRequires: lua >= 5.2
Conflicts: lua <5.2

happy new year
adrian

--

Adrian Schroeter
email: adrian@xxxxxxx

SUSE Linux GmbH, GF: Felix Imendörffer, Jane Smithard, Graham Norton, HRB 21284
(AG Nürnberg)

Maxfeldstraße 5
90409 Nürnberg
Germany


--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-packaging+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References