Mailinglist Archive: opensuse-packaging (129 mails)

< Previous Next >
[opensuse-packaging] RPM require version range
  • From: Ferdinand Thiessen <f.thiessen@xxxxxx>
  • Date: Mon, 4 Jan 2016 07:41:16 +0100
  • Message-id: <568A140C.3090607@gmx.de>
Hi,

How do I require a version range?
E.g. I need lua 5.2.x I tried:

BuildRequires: Lua(devel) >= 5.2, Lua(devel) < 5.3

But this will fail with a "Have choice" error, so rpm / buildservice
finds lua 5.1 and lua 5.2 for BuildRequire " Lua(devel) < 5.3". So it
does not combine the two statements.

Regards,

Ferdinand
--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-packaging+owner@xxxxxxxxxxxx

< Previous Next >