Mailinglist Archive: opensuse-packaging (118 mails)

< Previous Next >
[opensuse-packaging] Apache 2.2 to 2.4 Migration
Hi

I have been trying to migrate an old apache module written for Apache 2.2 to
Apache 2.4

To be honest, I do not have any experience with writing or packaging apache
modules before.

So I am trying to find out if there are any patches for any modules that went
through this phase, especially the ones which have used the ap_requires API.

The release notes page
http://httpd.apache.org/docs/2.4/developer/new_api_2_4.html says:

=====
ap_requires()
The core server now provides better infrastructure for handling Require
configuration. Register an auth provider function for each supported entity
using ap_register_auth_provider(). The function will be called as necessary
during Require processing. (Consult bundled modules for detailed examples.)
=====

However, I am not able to find the bundled modules that does this. Also, based
on my google search results, I could find only abandoned modules which never
migrated to 2.4 because of the ap_requires API usage. So, can any of you point
me to a patch/module, where the migration from 2.2 to 2.4 went through fine,
even with the use of this API ?

Thanks.

--
Sankar

--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-packaging+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages