Mailinglist Archive: opensuse-packaging (118 mails)

< Previous Next >
[opensuse-packaging] Sricplet in spec
  • From: Eric Schirra <ecsos@xxxxxxxxxxxx>
  • Date: Sat, 13 Jun 2015 12:59:24 +0200
  • Message-id: <3757053.fGcuj0DPOz@client1>
Hello,

i hope someone can help me.

I wan't to add scriptlet in spec.
It should run only at upgrade a package not run by new install.

So i insert something like:

%post
if [ "$1" = 2 ]; then
%{_bindir}/php %{my_path}/%{name}/console param
fi

I have try [ "$1" -gt 1 ] too without right result.

Obs will run this at build.
And so an error is rising up.

Can i prevent this from running at build?
It should run only at package-install or upgrade.

Or is something wrong at my code?
Or is something missing in Requires?

Best regards
Eric

--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-packaging+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups