Mailinglist Archive: opensuse-packaging (102 mails)

< Previous Next >
[opensuse-packaging] heads-up: dropping SLE11 compatibility in d:l:python and python3
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Folks,

I'll be disabling builds for SLE11 in the following repositories:
devel:languages:python
devel:languages:python3
The SLE11 repository will not be removed; if you *want* to build for SLE11,
you can explicitly enable it for your package.

I have also already started declining requests to these repos that contain
SLE11 compatibility conditionals (%if %suse_version < 1230 or lower). This
only applies to newly-added conditionals, and new package submits: If you're
only updating a package that already has this in the spec file, the request
will be accepted.
I'll still accept requests with conditionals, IF you ask for it in the request
message; our goal is simply to make this an exception and not the default.
(Fellow d:l:py reviewers, please consider adopting this policy too.)
The py2pack tool currently generates some compatibility conditionals like
this, i'll try to get it updated so that a newly generated spec will be
acceptable.

In other words, feel free to submit packages that don't build on SLE11.

m.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2

iQIcBAEBCAAGBQJU6y3jAAoJEIskb84DCy7LiK0QAIYODvyw5yHeKIxyKEPHRdCm
BkqxLp8eALZCfngURzodCytj7qODTWo8IRr/W6LWUGqrPDwwwLmw1X2Yd5dl2fQw
Ozw9Kcz+pt0MBKuR6Xp9ypRRUqcdGCjqDehO5TG5rGgJguWRNu2YcV3qPsGLEfGW
u2M74Qw3b/ILpmUTXJlV7gHAayUAJ1d0QhvtWNp0XDaDkGsl5+rKSaoY/3CJ7rwZ
889w82SiPvdh4nMAegu7uZYXtZFkd+xePl9OwKeG8I2o2IqVg/mb2Wr1/asIoTNq
nikOdyZbjpSXWDVH2uPKTG7SkHrSAE+CfadOWv8mEuO4cdhD0Uj9GubcJ6e9eSU/
HPfeGe/DFi0EXq57uG70gW/8SKkM33yet6l3ulqaiHgqYIfz8k6YovceHQGT8pHb
V5G+nGWld2Sn79g6WibPZOfMuS9dMU07nQFiUAioddekJyEwTSVlT7BVS+AhiM/g
ZhP8lZXnHBB7EA0PgsgRJfm9OqcNZETyyk6VWcSm0PyKQFzBPcGiQcKKWU4Vfq3/
J2HdBT518zCJurVKfNU4c/rBye2Q/gSQAUoa+ITUSZRyqeVIIyt00DX/MTPkYzPN
Yy0eUIW9pPBuAcbZnofqwL9ljasYOcYCM6GvmJ6uBTAIe4kHAcaPC7UArA9A7M90
IIMPKmcfr6CpZ/jYcBT8
=mJBy
-----END PGP SIGNATURE-----
--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-packaging+owner@xxxxxxxxxxxx

< Previous Next >