Mailinglist Archive: opensuse-packaging (155 mails)

< Previous Next >
Re: [opensuse-packaging] -DCMAKE_INSTALL_PREFIX does not work
On Wednesday 29 January 2014 13:26:25 Raymond Wooninck wrote:

On Wednesday 29 January 2014 11:50:50 Ilya Chernykh wrote:
This problem exists in nearly every package based on cmake. When I am trying
to build a cmake application for KDE3 (where it should be in /opt/kde3
prefix), it gets installed in /usr. I already abandoned several packages
and in other ones I manually patched the makefiles. Is there a general way,
or CMAKE is just a buggy crap?

Ilya,

Can you copy&paste that part of the spec-file where you call cmake ? For
KDE4
and KF5 we are utilizing this parameter and there things are working fine.

Raymond

I tried

%cmake .. -DCMAKE_INSTALL_PREFIX=/opt/kde3 \
          -DCMAKE_VERBOSE_MAKEFILE=OFF \
          -DQT_PREFIX_DIR=/usr/lib/qt3 \
          -DQT_LIBRARY_DIR=/usr/lib/qt3/%_lib \
          -DWITH_ALL_FEATURES=ON \
          -DWITH_TIFF=OFF \
          -DWITH_ASPELL=OFF \
          -DWITH_HUNSPELL=OFF \
          -DWITH_MAD=OFF \
          -DWITH_OPENEXR=OFF \
          -DWITH_LIBART=OFF

Also just cmake without the %. Also tried to put the .. in the end.
--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-packaging+owner@xxxxxxxxxxxx

< Previous Next >