Mailinglist Archive: opensuse-packaging (155 mails)

< Previous Next >
Re: [opensuse-packaging] Re: RPM in openSUSE 13.1
On Freitag, 17. Januar 2014, 08:54:03 wrote Andreas Jaeger:
Looking at the provides of the two packages:

$ rpm -q --provides alsa-plugins-pulse-32bit
alsa-plugins-pulse-32bit = 1.0.27-3.1.1
alsa-plugins-pulse-32bit(x86-32) = 1.0.27-3.1.1
libasound_module_conf_pulse.so
libasound_module_ctl_pulse.so
libasound_module_pcm_pulse.so

And looking at the 32-bit package:
$ rpm -qp --provides alsa-plugins-pulse-1.0.27-3.1.1.i586.rpm
alsa-plugins-pulse = 1.0.27-3.1.1
alsa-plugins-pulse(x86-32) = 1.0.27-3.1.1
config(alsa-plugins-pulse) = 1.0.27-3.1.1
libasound_module_conf_pulse.so
libasound_module_ctl_pulse.so
libasound_module_pcm_pulse.so

So, I propose to add:
Requires: libasound_module_conf_pulse.so
Requires: libasound_module_ctl_pulse.so
Requires: libasound_module_pcm_pulse.so

And use

%if 0%{?suse_version}

around it. Note the question mark which was not in former mails.
That way rpm-build will not fail, if that macro is not set at all (eg. on
Fedora).

good morning
adrian

either of these three lines should work but adding all three will not
harm ;)

Marco, does this work for you?

thanks a lot for fixing Skype properly for openSUSE!
Andreas


--

Adrian Schroeter
email: adrian@xxxxxxx

SUSE LINUX GmbH, GF: Jeff Hawn, Jennifer Guild, Felix Imendörffer, HRB 21284
(AG Nürnberg)
Maxfeldstraße 5
90409 Nürnberg
Germany



--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-packaging+owner@xxxxxxxxxxxx

< Previous Next >