Mailinglist Archive: opensuse-packaging (155 mails)

< Previous Next >
Re: [opensuse-packaging] Using "~" in package version?
On Dec 23, 2013, at 1:30 PM, Jason Craig <os-dev@xxxxxxxxxxx> wrote:

On 12/19/2013 01:20 AM, Johannes Meixner wrote:
On Dec 19 10:53 Andrey Borzenkov wrote (excerpt):
Is using something like 2.02~beta1 acceptable? Brief check suggests
that RPM does support it and sorts this before 2.02, but may be there
are guidelines for it?
Since which openSUSE release is it supported BTW?

To be on the safe side I would not use it because it depends
on the package installation tools on the target system where
the binary RPM would be installed if 2.02~beta1 is newer than 2.02
or if 2.02~beta1 is older than 2.02, see

...

Currently I do not have openSUSE 12.x systems running so that I cannot
test the behaviour there.

The link that Jan provided stated that it is in rpm 4.10 and backported to
4.9.1 for openSUSE 12.2.

I can confirm that the version comparison test works properly in openSUSE 12.2.

However, as Johannes noted, the version of RPM shipped with SLES 11 (even SP3)
is much older (4.4.2.3) and marks 2.02~beta1 as newer than 2.02. Most of the
repos in the build service build for both SLES 11 and all supported releases of
openSUSE, so unless your package is explicitly for openSUSE only, you should
not rely on this.

--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-packaging+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages