Mailinglist Archive: opensuse-packaging (114 mails)

< Previous Next >
Re: [opensuse-packaging] python issue I don't understand
Just to clarify the side-issue, you habe to buildrequire "python". It contains the SSL module.


Am 28. Dezember 2013 20:07:53 schrieb Jason Craig <os-dev@xxxxxxxxxxx>:

On 12/28/2013 10:36 AM, Greg Freemyer wrote:
> I'm trying to package the Google Cloud Print client
>
> home:gregfreemyer:Tools-for-forensic-boot-cd CUPS-Cloud-Print
>
> (note: The WebUI seems to be down currently)
>
> If I comment out "/usr/lib/cloudprint-cups/upgrade.py" from the %post
> section it builds fine.
>
> Further, after I install the RPM, I can run upgrade.py manually and it
> works fine.
>
> If I uncomment it, then I get a failure during build even against openSUSE_13.1:
>
> Traceback (most recent call last):
> [ 113s] File "/usr/lib/cloudprint-cups/upgrade.py", line 19, in <module>
> [ 113s] from oauth2client import client
> [ 113s] File "/usr/lib/cloudprint-cups/oauth2client/client.py",
> line 26, in <module>
> [ 113s] import httplib2
> [ 113s] File
> "/usr/lib/python2.7/site-packages/httplib2/__init__.py", line 908, in
> <module>
> [ 113s] class HTTPSConnectionWithTimeout(httplib.HTTPSConnection):
>
> My googling implies I just need to BuildRequires openssl and
> libopenssl-devel and it should resolve the issue. I've got both in
> the specfile now, but it is still failing.
>
> The other web claim is I need to rebuild python with SSL support, but
> I'm using openSUSE_13.1 in both my local machine and in the chroot
> jail, so the python modules should be the same. I'm not sure what I'm
> doing wrong.

OBS restricts Python packages from downloading anything during the build process. This is so that setuptools doesn't automatically download and install dependencies on the build system (as it will do) and produce a package which does not have the right requirements to run correctly when installed.

I only briefly glanced at the source, but it looks like upgrade.py wants to download new print drivers or something. AFAIK there is no way to get this to work--everything the Python package needs to install should be in the source or OBS.

--Jason Craig
--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-packaging+owner@xxxxxxxxxxxx




--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-packaging+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups