Mailinglist Archive: opensuse-packaging (266 mails)

< Previous Next >
Re: [opensuse-packaging] removal help -line: %suse_update_config.
On Sun, Nov 25, 2012 at 04:07:50PM +0100, Andreas Jaeger wrote:
On 11/25/2012 02:30 PM, doiggl@xxxxxxxxxxxxxxxxxx wrote:
Hello

How is the following error fixed:
Thanks Glenn

Part of log shown below.
Full Log see [1]
Here is the spec file[2]

Question:
What can replace this section ?
%{?suse_update_config:%{suse_update_config -f}}
aclocal --force
libtoolize --force
autoconf --force
autoheader --force
automake -afc
[...]

See below in the warning message:

[ 59s] + echo 'WARNING: REMOVE %suse_update_config. If your sources are
really'
[ 59s] WARNING: REMOVE %suse_update_config. If your sources are really
[ 59s] + echo 'too old to cover current architectures, prefer autoreconf
--force --install'
[ 59s] too old to cover current architectures, prefer autoreconf --force

so, in your case, just remove the suse_update_config line, it's not needed
at all,

Actually it might be needed on older software (>5 years) as it will not
build stuff for powerpc and other architectures. But usally not.

We had to fix 3 - 5 packages for power after this removal.

Ciao, Marcus
--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-packaging+owner@xxxxxxxxxxxx

< Previous Next >
References