Mailinglist Archive: opensuse-packaging (266 mails)

< Previous Next >
Re: [opensuse-packaging] How to find out which dependency installed a package?
On 11/22/2012 07:10 PM, Guido Berhoerster wrote:
* Ralf Lang <lang@xxxxxxxxxxxxx> [2012-11-22 18:52]:
horde5-content has conflicts for SLES11 because it prefers php53 but
something forced "php5" to be installed. How can I find out which
package(s) in the dependency tree forced this?

You can try "rpm -q --whatrequires php5" from within the build chroot.

Be aware that this one only returns packages which require php5 directly - but not its provides or files.

Just compare the list returned from command above with dependency conflicts you get trying to remove the package (may not be case of this particular package, though)

Jiri



--
Regards,

Jiri Srain
Project Manager
---------------------------------------------------------------------
SUSE LINUX, s.r.o. e-mail: jsrain@xxxxxxxx
Lihovarska 1060/12 tel: +420 284 084 659
190 00 Praha 9 fax: +420 284 084 001
Czech Republic http://www.suse.com
--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-packaging+owner@xxxxxxxxxxxx

< Previous Next >