Mailinglist Archive: opensuse-packaging (140 mails)

< Previous Next >
[opensuse-packaging] generic provides for MPI environments
  • From: todd rme <toddrme2178@xxxxxxxxx>
  • Date: Wed, 4 Jan 2012 16:44:49 +0100
  • Message-id: <CADb7s=umsUzqfDjQtVJWybk5Hk6t4tNTbwVDb4F-2efdgKdgUg@mail.gmail.com>
There are currently at least 3 MPI (message passing interface)
environments provided by openSUSE: lam, mpich, and openmpi. Packages
related to MPI, like mpi-selector, and python-pypar, require an MPI
environment be installed, but do not care which it is as long as it is
compliant with the MPI standard. There is no easy way to specify this
in the requires, however.

What does everyone think about having a generic provides for MPI
environments, such as pkconfig(MPI), that each of these can provide
and that other packages could require in order to be MPI
environment-agnostic? If so, what would be the best name for it?

-Todd
--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-packaging+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
Follow Ups