Mailinglist Archive: opensuse-packaging (144 mails)

< Previous Next >
Re: [opensuse-packaging] cups: upgrade from 1.4.x to version 1.5.0
  • From: Werner Flamme <werner.flamme@xxxxxx>
  • Date: Fri, 04 Nov 2011 09:43:56 +0100
  • Message-id: <>
Hash: SHA1

Stefan Seyfried [03.11.2011 16:52]:
On 03.11.2011 16:48, Werner Flamme wrote:

All print servers are in DNS with their FQDN, and the error came
up on all clients that tried to contact the print servers via
FQDN. As soon as they switched to using the short name,
everything went well.

The DNS translates short name and FQDN to exactly the same

In my case it was the same. I needed to put them into /etc/hosts. I
did not investigate it more deeply, just putting everything into
/etc/hosts did work for me.

I just wanted to spell out that this does not have to be a CUPS
1.5 issue, but that I had seen similar things in 1.4

And I tried to say that in my case, everything went fine with the
latest CUPS 1.4.6 in the Printing:SLE_11_SP1 repo. I never had
problems with connecting to my CUPS servers. And the config wasn't
changed by the update from 1.4.6 to 1.5.0.

BTW, if DNS could not resolve the FQDN, IMHO I'd never get "Bad
request", but "Connection timed out" or "Server not found" :-(

This is not a DNS issue but has to do with who the cups server
thinks he is, AFAICT.

Yes sir :-). And why would the CUPS server think it isn't the one
specified as ServerName in cupsd.conf? Why do I enter a server name
here? Of course this host name is written to /etc/hosts, with the
correct IP address. Like printlpz1l

And the server responds when the URL starts with
""; or with "http://printlpz1l:631";. But it
does not respond when the URL starts with
""; (same with "https://";, same
with "lpstat -h ... -a").

And the xinetd service cups-lpd works fine all the time... obviously
(and luckily), there is no "spoof protection".

Version: GnuPG v2.0.16 (GNU/Linux)
Comment: Using GnuPG with Mozilla -

To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-packaging+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups