Mailinglist Archive: opensuse-packaging (284 mails)

< Previous Next >
Re: [opensuse-packaging] nginx-0.8?
El 08/02/11 10:36, Marcus Rueckert escribió:
On 2011-02-08 14:33:05 +0100, Ludwig Nussel wrote:
Also I still think that having a package name that looks like
version-release is just confusing. There should be a policy against
it.

apache vs apache2
samba vs samba4
sqlite vs sqlite2 vs sqlite3 (a good example how not to do it)
kde3-* vs kde4-* vs no prefix (another good example why you want to
stick to names, once you gave a thing
a name)
rubygem-rails-2_3 ...

i could go on for a while

darix


And there is another odd issue..

sudo LC_ALL=C zypper in -n nginx-0.8
Loading repository data...
Reading installed packages...
Resolving package dependencies...

The following NEW packages are going to be installed:
apache2 apache2-itk apache2-utils git-web nginx-0.8 ruby ruby-devel
rubygem-daemon_controller rubygem-fastthread rubygem-file-tail
rubygem-passenger rubygem-passenger-nginx rubygem-rack rubygem-rake
rubygem-spruz rubygems

16 new packages to install.
Overall download size: 11.0 MiB. After the operation, additional 41.6
MiB will be used.
Continue? [y/n/?] (y):

Why it is getting apache git and rubygems installed (!)
--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-packaging+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups