Mailinglist Archive: opensuse-packaging (284 mails)

< Previous Next >
Re: [opensuse-packaging] Need help with libname.
  • From: Dave Plater <davejplater@xxxxxxxxx>
  • Date: Sat, 05 Feb 2011 04:15:30 +0200
  • Message-id: <4D4CB2C2.60102@gmail.com>
On 02/05/2011 03:12 AM, Philipp Thomas wrote:
[Please, no extra copy via private mail as I do read the list]

On Fri, 04 Feb 2011 23:22:45 +0200, Dave Plater
<davejplater@xxxxxxxxx> wrote:


Am I correct in saying that a full stop "." isn't allowed to be in the
library name and needs to be replaced with an underscore "_" ?

Yes, that' what the shared library policy tells you.

It does now after I updated the wiki, IIRC the old one said that, the
new one didn't but it's something I won't forget anymore.

Meanwhile you wouldn't have an idea why libtool is naming the devel .so
link incorrectly. You can see it taking place in the makeinstall section
of the log?

You tell me what project we're talking about and I'll have a look if
time permits. I guess I have a few ideas why something like that can
happen but I'd like to look first.

Philipp

You have a choice with home:plater/mjpegtools and
multimedia:libs/mjpegtools or the unfixed openSUSE:Factory/mjpegtools
that's broken gstreamer-0_10-plugins-bad.
If you look at the requires of gstreamer-0_10-plugins-bad you'll see
that it doesn't know where the two libs from mjpegtools come from.
I'm still not sure if the gstreamer build is fixed because factory
builds are stuck and it doesn't build for < 11.4 and mjpegtools is
waiting to be checked in.
Vincent Untz went to the conference.
Thanks
Dave P
--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-packaging+help@xxxxxxxxxxxx

< Previous Next >