Mailinglist Archive: opensuse-packaging (250 mails)

< Previous Next >
[opensuse-packaging] Supplements package with a required version
  • From: Lubos Lunak <l.lunak@xxxxxxx>
  • Date: Sun, 30 Aug 2009 23:38:29 +0200
  • Message-id: <200908302338.29230.l.lunak@xxxxxxx>

Hello,

I have package mozilla-xulrunner191, which can make use of package
mozilla-xulrunner191-kde4, but only of a specific version. How do I express
that using rpm dependencies?

Currently the -kde4 package has "Supplements:
packageand(mozilla-xulrunner191:kdebase4-workspace)" to be pulled in when
both the main package and the KDE desktop are installed. I however don't know
how to express the version dependency, since the -kde4 package does not care
what the version of the main package is, but the main package has a version
requirement on the -kde4 package, if it is installed. I cannot use Requires
in the main package, since -kde4 is optional. If I use Recommends in the main
package, I don't know how to recommend the -kde4 package only if KDE is also
installed.

Is there a way?

--
Lubos Lunak
KDE developer
--------------------------------------------------------------
SUSE LINUX, s.r.o. e-mail: l.lunak@xxxxxxx , l.lunak@xxxxxxx
Lihovarska 1060/12 tel: +420 284 028 972
190 00 Prague 9 fax: +420 284 028 951
Czech Republic http://www.suse.cz
--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-packaging+help@xxxxxxxxxxxx

< Previous Next >
List Navigation
This Thread
  • No further messages