Mailinglist Archive: opensuse-packaging (83 mails)

< Previous Next >
Re: [opensuse-packaging] How to set javac target ?
  • From: Bernhard Walle <bwalle@xxxxxxx>
  • Date: Mon, 27 Oct 2008 14:26:39 +0100
  • Message-id: <20081027142639.4b89a01b@xxxxxxxxxxxx>
* Stefan Dirsch [2008-10-27 14:15]:

Ok. So this basically means that packaging .jar files is impossible
using our buildservice. :-( Still the error message is confusing.

Well, I guess it's against our policy to ship "binaries". But the
technical benefits of recompiling Java class files are quite small
compared to the technical benefits of recompiling machine code.

During compilation the java target version can be set with: javac
-target 1.5 for example.

According to the Geotag website you need eclipse to build the sources.

http://geotag.sourceforge.net/?q=node/23

Not sure how this is supposed to work in our buildservice. :-(

Well, I think you don't *need* but he uses it. So, you still can
write a custom build.xml for Ant (some "make for java"). But
honestly I also would think twice if I would do that ... or just
install the software locally. ;)


Regards,
Bernhard
--
Bernhard Walle, SUSE Linux Products GmbH, Architecture Development
--
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-packaging+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups