Mailinglist Archive: opensuse-packaging (57 mails)

< Previous Next >
[opensuse-packaging] xulrunner / gecko update
  • From: Wolfgang Rosenauer <stark@xxxxxxx>
  • Date: Wed, 23 Aug 2006 09:43:27 +0200
  • Message-id: <20060823074327.GA25238@xxxxxxx>
Hi,

on SUSE Linux 10.1 we have the two packages
mozilla-xulrunner and its devel package gecko-sdk to get the mozilla
development environment for embedding gecko into other applications.
(Gecko 1.8.0.x based)

This has changed some time ago in FACTORY and now we have the following
package structure:

mozilla-xulrunner180
mozilla-xulrunner180-devel

mozilla-xulrunner181
mozilla-xulrunner181-devel

mozilla-xulrunner180 replaces the old mozilla-xulrunner and gecko-sdk
packages by providing the correct RPM provides. So you didn't notice so
far probably.

If your package requires mozilla-xulrunner or needs gecko-sdk to build
you should now change to one of the new names in Requires and
BuildRequires.
And in addition you should try to build against the 181 version which is
a snapshot of the upcoming Gecko 1.8.1. If it's possible (means every
application works with 1.8.1 we will drop the 1.8.0 version before
10.2)



Wolfgang

--
SUSE LINUX GmbH -o) Tel: +49-(0)911-740 53 0
Maxfeldstr. 5 /\\ Fax: +49-(0)911-740 53 679
90409 Nuernberg, Germany _\_v
---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-packaging+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-packaging+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages