Mailinglist Archive: opensuse-multimedia (5 mails)

< Previous Next >
Re: [opensuse-multimedia] Midi questions [solved]
  • From: Pedro Lopez-Cabanillas <pedro.lopez.cabanillas@xxxxxxxxx>
  • Date: Sun, 17 Jan 2010 10:23:28 +0100
  • Message-id: <201001171023.28995.pedro.lopez.cabanillas@xxxxxxxxx>
On Saturday, January 16, 2010, Koenraad Lelong wrote:
I finally tried again, after having some troubles again.
I seems that if fluidsynth runs as root, it (mostly) works fine but when
I run it as an ordinary user, I get distorted output.
I didn't use qsynth this time, altough the problems are similar.

Any more suggestions ? What can I do to help this get sorted out ?

It is hard to diagnose with only a "distorted output" description. Maybe it is
a problem with xruns? in this case, try increasing the buffer sizes. If you
are using the alsa audio output:

$ fluidsynth -a alsa -oaudio.period-size=1024 -oaudio.periods=4 soundfont.sf2

It is much more comfortable using QSynth, the fields are labeled "Buffer Size"
and "Buffer Count" in the audio tab of the setup dialog. The minimum nubers
are very dependent on the soundcard model.

Did you see warnings like these?
fluidsynth: warning: Failed to pin the sample data to RAM; swapping is
fluidsynth: warning: Failed to set thread to high priority

The above warnings are about the realtime priority, and can be solved adding
the following lines to the file /etc/security/limits.conf and adding yourself
to the audio group:
@audio - rtprio 90
@audio - memlock unlimited

Please read this article:

BTW, have you tried kmid2?

To unsubscribe, e-mail: opensuse-multimedia+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-multimedia+help@xxxxxxxxxxxx

< Previous Next >
List Navigation