Mailinglist Archive: opensuse-mobile-de (414 mails)

< Previous Next >
Re: [suse-laptop] Wie kann ich ein PCMCIA Netwerkkartentreibermodul automatisch laden?
Liebe Liste!

Der unten angeführte Betrag hat mich auf die richtige Spur gebracht.
Hotplug hat das falsche Modul (nähmlich 8139cp statt rtl8139
geladen). Da die Syntax von /etc/hotplug/pci.handmap nicht trivial
ist, hat es einige Zeit gedauert, bis ich verstanden habe, dass ich
nur den entsprechenden (und richtigen) Eintrag von
/lib/module.pcimap kopieren musste. (Eine falsche Eintragung hatte
ich schon vorher). Der richtige Eintrag (=Zeile in module.pcimap)
kann natürlich nur über scanpci (Device ID und Vendor ID stimmen
überein) gefunden werden. Für diese Kombination (Device ID und
Vendor ID) gibt es in /lib/modules.pcimap für die Realtek 8139
zumindest 3(!) mögliche Treiber (8139cp, 8139too, rtl8139, weiter
habe ich nicht gesucht) und es wird natürlich immer der erstbeste
herangezogen. Welcher der richtige ist und die Realtekkarte zum
blinken bringt (d.h. die Statusanzeige soweit vorhanden), sollte
vorher mit modprobe probiert werden. Alles weitere wird dann von den
Yast Einstellungen übernommen.

Ich hoffe, eine Beschreibung des Problems und die Lösung findet einen
Weg in die Supportdatenbank!

Danke für Eure Hilfe!

Edgar

> On Thu, Jan 08, Dominik Zindel wrote:
> > Hallo Liste
> >
> > Ich hatte ein ähnliches Problem: Meine WLAN-PCMCIA-Card musste
ich
> > immer durch Eingabe von ca. 5 Zeilen von Hand aktivieren. Und
zwar als
> > root. Nun habe ich die Befehle in die Datei file:/etc/rc.d/rc
> > eingetragen (ich hab sie einfach am Schluss hinzugefügt). Nun
werden
> > diese Aktivierungsbefehle beim Systemstart (noch als root) immer
> > ausgeführt. Hat natürlich den Nachteil, dass die Karte beim
Starten im
> > Slot sein muss. Bin mir auch bewusst, dass dies wohl nicht die
> > perfekte Lösung ist - aber sie funktioniert bei mir...
>
> Lest doch einfach mal das Handbuch, den PCMCIA Abschnitt im Laptop
> Kapitel und das Hotplug Kapitel.
>
> Wenn es eine PC-Karte ist, dann muß ein Eintrag in
/etc/pcmcia/config
> bzw. /etc/pcmcia/*.conf gemacht werden. Für CardBus Karten (z.B.
die
> Realtek von Edgar) fehlt ein Eintrag in /etc/hotplug/pci.handmap.
>
> Wie das geht steht im Handbuch.
> /etc/sysconfig/hotplug:HOTPLUG_DEBUG="yes"
>
> > Am Donnerstag, 8. Januar 2004 10:26 schrieb Edgar Piskernik:
> > > Liebe Liste!
> > >
> > > Nach vielen Stunden Recherche habe ich meine Realtek 8139
PCMCIA
> > > Netzwerkkarte (eine Surecom 428X 10/100 MBit) endlich zum
laufen
> > > gebracht. Die Karte wird zwar von Yast richtig erkannt (Realtek

> > > 8139) aber das entsprechende Modul wird offensichtlich nicht
> > > geladen. Wie kann ich Suse Linux bzw. hotplug dazu bewegen, die

> > > unten angeführten Maßnahmen (vor allem modprobe rtl8139) beim
> > > Anschliessen der Karte richtig durchzuführen?
> > >
> > > Situation:
> > > Die Netwerkkarte wurde von mir in Yast 2 als eth-pcmcia mit den

> > > richtigen Angaben versehen (IP, Gateway usw.) ifconfig bringt
nur
> > > lo, ein ping auf lo ist problemlos möglich. eth0 ist mit
ifconfig
> > > nicht sichtbar.
> > >
> > > Mein Vorgehen war folgendermaßen:
> > >
> > > modprobe rtl8139
> > > #also offensichtlich nicht mehr rtl8139too wie in der
> > > #Supportdatenbank
> > > für Kernel 2.4 beschrieben?
> > >
> > > ifconfig -a
> > > # zeigt nun die Karte als eth0 ohne Einstellungen
> > >
> > > ifconfig eth0 <IP ADRESSE> netmask 255.255.255.0 broadcast
> > > <BROADCAST Adresse = wahrscheinlich IP mit letzer Stelle 255>
> > >
> > > route -n #zeigt nichts
> > >
> > > #folgende Route habe ich später in die Datei routes eingetragen
und
> > > müssen nun nicht mehr manuell gestartet werden.
> > >
> > > route add -net 127.0.0.0 netmask 255.255.255.0 dev lo
> > > route add default gw <IP ADRESSE GATEWAY>
> > >
> > > #Nach einem
> > > rcnetwork restart
> > > #funktioniert die Netwerkverbindung dann.
> > >
> > > Zu meinem System:
> > > Toshiba 7200ct mit Pentium III-M Speedstep mit 600MHz
> > > Suse Linux 9.0 mit Kernelupdate vom 16. Dezember (166)
> > > Surecom 428X PCMCIA Netzwerkkarte (Realtek 8139)
> > >
> > > Hat jemand eine Idee?
> > >
> > > Danke,
> > >
> > > Edgar
> >
> > --
> > ------
> > Dominik Zindel
> > rte Bel-Air 24
> > 1723 Marly
> > Tel 026 436 48 50
> > Natel 079 207 00 65
> > dominik@xxxxxxxxxx
> > www.zindel.org
> > ICQ 346494515
> >
> >
> > --
> > Um die Liste abzubestellen, schicken Sie eine Mail an:
> > suse-laptop-unsubscribe@xxxxxxxx
> > Um eine Liste aller verfügbaren Kommandos zu bekommen, schicken
Sie
> > eine Mail an: suse-laptop-help@xxxxxxxx
> >
> >
>
> --
>
> ciao, christian
>
> -----------------------------------------------------
> From http://www.yetilab.de/fehler/f404.html:
> "Noch zwei Wochen Informations-Müll produzieren,
> und dann: *pffftt*, ab in den Papierkorb!"
> -----------------------------------------------------
>
> --
> Um die Liste abzubestellen, schicken Sie eine Mail an:
> suse-laptop-unsubscribe@xxxxxxxx
> Um eine Liste aller verfügbaren Kommandos zu bekommen, schicken
> Sie eine Mail an: suse-laptop-help@xxxxxxxx

>
>


< Previous Next >
This Thread
  • No further messages