Mailinglist Archive: opensuse-m17n (69 mails)

< Previous Next >
UTF-8 and Turkish
  • From: Togan Muftuoglu <toganm@xxxxxxxxxxxx>
  • Date: Mon, 13 May 2002 11:23:55 +0000 (UTC)
  • Message-id: <20020513112228.GB2170@xxxxxxxxxxxx>
Hi,

I am trying to use UTF-8 as the the locale environment under SuSE 8.0. I
have some problematic areas where I have not find a solution yet. Hence
I need assistance

This is what I have under $HOME/.profile

export LANG="turkish"
export LC_CTYPE="tr_TR.utf8"
export LC_NUMERIC="tr_TR.utf8"
export LC_TIME="POSIX"
export LC_COLLATE="POSIX"
export LC_MONETARY="tr_TR.utf8"
export LC_MESSAGES="en_US"
export LC_PAPER="tr_TR.utf8"
export LC_NAME="tr_TR.utf8"
export LC_ADDRESS="tr_TR.utf8"
export LC_TELEPHONE="tr_TR.utf8"
export LC_MEASUREMENT="tr_TR.utf8"
export LC_IDENTIFICATION="tr_TR.utf8"

Under KDE-> Control Center -> Personalization -> Country and language I
have Country as Turkey language as English.

I did not install kde-i18n related packages as I do not use the system
other than English, however I do create documents in Turkish and I
type using the Turkish keyboard.
1) When I type locale charmap I get UTF-8 so my understanding is I am
using UTF-8

2) I use "utf8xterm" shell script that comes with shtools-2002.01.30-39
and

a) I can type all the turkish characters in the Xterm environment
created by this script

b) I can use Vim and type the Turkish characters ş (scedilla) ğ (gbreve)
ı (idotless) İ (Iabovedot) hence I can use Mutt and type these
characters and read them.

c) same is true if I just open a konsole with KDE
d) When I use "xev" pressing the keys scedila gbreve idotless Iabovedot
produces empty. So just to test I made a symbolink link under
/usr/lib/locale for tr_TR.UTF-8 which is pointing to tr_TR.utf8. When I
export tr_TR.UTF-8 for LC_CTYPE and use "xev" this time I get back the
desired output. However this causes Netscape 4.79 to behave strange and
I can not use Netscape.

e) if LC_CTYPE is tr_TR.utf8 then under emacs I can not type the
scedilla, idotless, gbreve, Iabovedot. I have the mule-ucs package
installed but still no hope. I tried with setting emacs language
environment to turkish but no. There must be something I need to tweak.
However I just use emacs for Docbook editing and thats all so I do not
know the internals .
So in short tp rephrase what do I have to do to have a proper UTF-8
environment which will enable me to type read in Turkish but provide me
all the menus and system messages in English

Thanks

--

Togan Muftuoglu
Unofficial SuSE FAQ Maintainer
http://dinamizm.ath.cx



< Previous Next >
Follow Ups