Mailinglist Archive: opensuse-kubic (54 mails)

< Previous Next >
[opensuse-kubic] New ARM Kubic snapshot 20200929 released!
  • From: Guillaume Gardet <guillaume.gardet@xxxxxxx>
  • Date: Thu, 01 Oct 2020 07:03:44 +0000
  • Message-id: <160153582451.5437.17899998738315963127@go-agent-stagingbot-1>

Please note that this mail was generated by a script.
The described changes are computed based on the aarch64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=kubic&groupid=3&version=Tumbleweed&build=20200929
https://bugzilla.opensuse.org/buglist.cgi?product=openSUSE%20Tumbleweed&component=Kubic&query_format=advanced&resolution=---

Please do not reply to this email to report issues, rather file a bug on
bugzilla.opensuse.org.
For more information on filing bugs please see
https://en.opensuse.org/openSUSE:Submitting_bug_reports
Packages changed:
libzypp (17.25.0 -> 17.25.1)
procps
python-attrs (19.3.0 -> 20.2.0)
python-pyzmq
zypper (1.14.39 -> 1.14.40)

=== Details ===

==== libzypp ====
Version update (17.25.0 -> 17.25.1)

- Fix bsc#1176902: When kernel-rt has been installed, the
purge-kernels service fails during boot.
- Use package name provides as group key in purge-kernel
(bsc#1176740 bsc#1176192)
kernel-default-base has new packaging, where the kernel uname -r
does not reflect the full package version anymore. This patch
adds additional logic to use the most generic/shortest edition
each package provides with %{packagename}=<version> to group the
kernel packages instead of the rpm versions.
This also changes how the keep-spec for specific versions is
applied, instead of matching the package versions, each of the
package name provides will be matched.
- version 17.25.1 (22)

==== procps ====
Subpackages: libprocps8

- Replace patch procps-ng-3.3.16-comm_len.patch with upstream
commitment patch procps-ng-3e1c00d0.patch (bsc#1158830)

==== python-attrs ====
Version update (19.3.0 -> 20.2.0)

- update to 20.2.0:
- Python 3.4 is not supported anymore.
- ``attr.define()``, ``attr.frozen()``, ``attr.mutable()``, and
``attr.field()`` remain **provisional**.
This release fixes a bunch of bugs and ergonomics but they remain mostly
unchanged.
Further changes see included CHANGELOG.rst

==== python-pyzmq ====

- raise test timeout limit to 5m and define an console encoding

==== zypper ====
Version update (1.14.39 -> 1.14.40)
Subpackages: zypper-needs-restarting

- info: Assume descriptions starting with '<p>' are richtext
(bsc#935885)
- version 1.14.40


--
To unsubscribe, e-mail: opensuse-kubic+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-kubic+owner@xxxxxxxxxxxx

< Previous Next >
List Navigation
This Thread
  • No further messages