Mailinglist Archive: opensuse-kubic (68 mails)

< Previous Next >
[opensuse-kubic] New MicroOS snapshot 20200311 released!
  • From: Richard Brown <rbrown@xxxxxxx>
  • Date: Sat, 14 Mar 2020 03:05:07 +0000
  • Message-id: <158415510707.25386.15515347950121450147@go-agent-stagingbot-3>

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=microos&groupid=1&version=Tumbleweed&build=20200311
https://bugzilla.opensuse.org/buglist.cgi?product=openSUSE%20Tumbleweed&component=MicroOS&query_format=advanced&resolution=---

Please do not reply to this email to report issues, rather file a bug on
bugzilla.opensuse.org.
For more information on filing bugs please see
https://en.opensuse.org/openSUSE:Submitting_bug_reports
Packages changed:
Mesa (20.0.0 -> 20.0.1)
Mesa-drivers (20.0.0 -> 20.0.1)
NetworkManager-applet (1.8.25+20 -> 1.16.0)
PackageKit (1.1.12 -> 1.1.13)
baloo5-widgets (19.12.2 -> 19.12.3)
checkpolicy (2.9 -> 3.0)
curl
dolphin (19.12.2 -> 19.12.3)
gdm
gnome-shell (3.34.4 -> 3.34.4+4)
gstreamer-plugins-bad
gstreamer-plugins-base
installation-images-MicroOS (14.459 -> 14.461)
kaccounts-integration (19.12.2 -> 19.12.3)
kate (19.12.2 -> 19.12.3)
kde-print-manager (19.12.2 -> 19.12.3)
kdialog (19.12.2 -> 19.12.3)
kernel-firmware (20200207 -> 20200302)
kio-extras5 (19.12.2 -> 19.12.3)
konsole (19.12.2 -> 19.12.3)
kwalletmanager5 (19.12.2 -> 19.12.3)
libcontainers-common (20191211 -> 20200306)
libinput (1.15.2 -> 1.15.3)
libnma (1.8.26 -> 1.8.28)
libselinux (2.9 -> 3.0)
libselinux-bindings (2.9 -> 3.0)
libsemanage (2.9 -> 3.0)
libsepol (2.9 -> 3.0)
open-vm-tools (11.0.0 -> 11.0.5)
patterns-base
perl-TimeDate (2.31 -> 2.32)
policycoreutils (2.9 -> 3.0)
python-semanage (2.9 -> 3.0)
restorecond (2.9 -> 3.0)
sddm
tracker
transactional-update (2.20.2 -> 2.20.3)

=== Details ===

==== Mesa ====
Version update (20.0.0 -> 20.0.1)
Subpackages: Mesa-libEGL1 Mesa-libGL1 Mesa-libglapi0 libgbm1

- update to Mesa 20.0.1
* bugfix release
- cleanup in specfile: get rid of is_opensuse macro, which is no
longer needed at all (jira#PM-1623)

==== Mesa-drivers ====
Version update (20.0.0 -> 20.0.1)
Subpackages: Mesa-dri Mesa-gallium

- update to Mesa 20.0.1
* bugfix release
- cleanup in specfile: get rid of is_opensuse macro, which is no
longer needed at all (jira#PM-1623)

==== NetworkManager-applet ====
Version update (1.8.25+20 -> 1.16.0)

- Update to version 1.16.0:
+ Turned libnma into an external dependency and move to
"https://gitlab.gnome.org/GNOME/libnma";. To build,
libnma-1.8.28 or newer is required.
+ The libnm-gtk, the deprecated libnm-glib compatibility library
was removed. Everybody should be using libnma by now.
+ Improve applet icons for hidpi.
+ Fix transparent dialog borders.
+ Updated translations.
- Drop nma-data sub-package.

==== PackageKit ====
Version update (1.1.12 -> 1.1.13)
Subpackages: PackageKit-backend-zypp libpackagekit-glib2-18

- Add patch to stop zypp backend failing on already installed packages
(boo#1155624)
+ Patch: PackageKit-zypp-revert-fail-on-already-installed.patch
- No longer recommend -lang: supplements are in use
- Fix autotools modifications in openSUSE vendor patch
+ Patch: PackageKit-dnf-Add-openSUSE-vendor.patch
- Update to version 1.1.13
+ New APIs for pk-client-helper in packagekit-glib2
+ dnf, zypp: Various fixes related to upgrades
+ Added support for user services
+ New plymouth "system-upgrade" and "reboot" modes used now
+ Add mutex lock to protect EULAs array
+ Correct bug tracker links on website
+ Support non-x86 arches in gstreamer helper
+ List installed, removed and obsoleted packages in pkcon get-updates
+ Properly mark obsoleted packages when simulating upgrade
+ Provide information about obsoleted packages
+ Return directly when its state is going backwards
+ Shrink the progress bar to fit when run in small spaces
+ Improve the 'using' documentation with a link to API
- Remove upstreamed patches:
+ PackageKit-add-mutex-lock-to-protect-backend-priv-eulas.patch
+ PackageKit-return-on-transactions-going-backwards.patch
+ PackageKit-zypp-dont-set-upgrade-mode-on-updating-specific-packages.patch
+ PackageKit-zypp-fix-newest-filter.patch
+ PackageKit-zypp-fix-what-provides-newest-filter.patch
+ PackageKit-zypp-get-files-string-array.patch
+ PackageKit-zypp-get-updates-dup-or-up.patch
+ PackageKit-zypp-upgrade-system.patch
+ zypp-perform-actions-disallowed-by-update-in-upgrade-mode.patch
+ 0001-dnf-Don-t-override-DnfContext-s-release_ver-for-the-.patch
+ 0001-dnf-Invalidate-the-sack-cache-after-downloading-new-.patch
+ 0001-offline-update-Use-new-plymouth-system-upgrade-and-r.patch
- Add new openSUSE specific patches for DNF backend:
+ PackageKit-dnf-Add-openSUSE-vendor.patch
+ PackageKit-dnf-Add-support-for-AppStream-repodata-basenames-use.patch
- Remove old openSUSE patches for the DNF backend:
+ 1001-dnf-Add-openSUSE-Tumbleweed-vendor.patch
+ 1002-dnf-Add-support-for-AppStream-repodata-basenames-use.patch
- Refresh patches:
+ PackageKit-drop-gtk2.patch

==== baloo5-widgets ====
Version update (19.12.2 -> 19.12.3)

- Update to 19.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.3
- No code change since 19.12.2

==== checkpolicy ====
Version update (2.9 -> 3.0)

- Update to version 3.0
* add flag to enable policy optimization
* allow to write policy to stdout
* remove a redundant if-condition

==== curl ====
Subpackages: libcurl4

- ignore_runtests_failure.patch: remove, no longer needed

==== dolphin ====
Version update (19.12.2 -> 19.12.3)
Subpackages: dolphin-part libdolphinvcs5

- Update to 19.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.3
- Changes since 19.12.2:
* Fix typo in comment
* Fix files not being highlighted if directory of file is already open
(kde#417230)

==== gdm ====
Subpackages: gdmflexiserver libgdm1 typelib-1_0-Gdm-1_0

- Add gdm-disable-wayland-on-mgag200-chipsets.patch: disable wayland
on mgag200 chipsets, this patch used to be part of
gdm-disable-wayland-on-unsupported-chipsets.patch which was dropped,
however the mgag200 part is still not fixed by upstream. So we should
keep this part to make sure GNOME works properly on mgag200 chipsets
(bsc#1162888, glgo#GNOME/mutter#57).

==== gnome-shell ====
Version update (3.34.4 -> 3.34.4+4)

- Drop gnome-shell-Avoid-loginDialog-grab-focus-when-locked.patch:
This patch will steal the mouse focus of the gdm greeter, drop
it to be aligned with upstream, let the first/only user entry of
gdm to be selected by default, and the bug the patch fixed can not
be reproduced in GNOME3.34 (bsc#1164856).
- Rebase gs-fate318433-prevent-same-account-multi-logins.patch and
gnome-shell-domain.patch.
- Update to version 3.34.4+4:
* shell: fix typo in comment
* global: force fsync() to worker thread when saving state
* overview: Hide the overview on session mode hasOverview changes
* closeDialog: Make dialog inactive while fading out

==== gstreamer-plugins-bad ====
Subpackages: libgstadaptivedemux-1_0-0 libgstbadaudio-1_0-0
libgstbasecamerabinsrc-1_0-0 libgstcodecparsers-1_0-0 libgstisoff-1_0-0
libgstmpegts-1_0-0 libgstphotography-1_0-0 libgstsctp-1_0-0
libgsturidownloader-1_0-0 libgstwayland-1_0-0 libgstwebrtc-1_0-0

- Fix conditionals passed to meson for 3'rd party building.

==== gstreamer-plugins-base ====
Subpackages: libgstallocators-1_0-0 libgstapp-1_0-0 libgstaudio-1_0-0
libgstfft-1_0-0 libgstgl-1_0-0 libgstpbutils-1_0-0 libgstriff-1_0-0
libgstrtp-1_0-0 libgstrtsp-1_0-0 libgstsdp-1_0-0 libgsttag-1_0-0
libgstvideo-1_0-0

- Add gstreamer-plugins-base-gl-deps.patch: Workaround incomplete
gstreamer-gl.pc file, which is missing the (dynamic) dependency
on wayland.
- Enable meson build conditionally for Tumbleweed.

==== installation-images-MicroOS ====
Version update (14.459 -> 14.461)

- merge gh#openSUSE/installation-images#363
- adapt system-user-* and system-group-* package handling
(bsc#1163938)
- 14.461
- merge gh#openSUSE/installation-images#362
- fix rescue system setup (bsc#1160378)
- 14.460
- Pull the correct distribution-logos per distribution theme

==== kaccounts-integration ====
Version update (19.12.2 -> 19.12.3)

- Update to 19.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.3
- Changes since 19.12.2:
* Unbreak the Accounts KCM (kde#415267)
* [CreateAccount job] Never set an empty name when creating an account
(kde#414219)

==== kate ====
Version update (19.12.2 -> 19.12.3)
Subpackages: kate-plugins

- Update to 19.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.3
- Changes since 19.12.2:
* appdata: improve URLs
* try to add enough large icons for Windows (256/512 px)

==== kde-print-manager ====
Version update (19.12.2 -> 19.12.3)

- Update to 19.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.3
- No code change since 19.12.2

==== kdialog ====
Version update (19.12.2 -> 19.12.3)

- Update to 19.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.3
- No code change since 19.12.2

==== kernel-firmware ====
Version update (20200207 -> 20200302)
Subpackages: kernel-firmware-all kernel-firmware-amdgpu kernel-firmware-ath10k
kernel-firmware-atheros kernel-firmware-bluetooth kernel-firmware-bnx2
kernel-firmware-brcm kernel-firmware-chelsio kernel-firmware-dpaa2
kernel-firmware-i915 kernel-firmware-intel kernel-firmware-iwlwifi
kernel-firmware-liquidio kernel-firmware-marvell kernel-firmware-media
kernel-firmware-mediatek kernel-firmware-mellanox kernel-firmware-mwifiex
kernel-firmware-network kernel-firmware-nfp kernel-firmware-nvidia
kernel-firmware-platform kernel-firmware-qlogic kernel-firmware-radeon
kernel-firmware-realtek kernel-firmware-serial kernel-firmware-sound
kernel-firmware-ti kernel-firmware-ueagle kernel-firmware-usb-network ucode-amd

- Update to version 20200302 (git commit 0148cfefcbf9):
* check_whence: python3/utf-8 support
* Makefile: improve `make check` usefulness
* mediatek: Remove in-tree symlinks
* qca: Fix blueooth firmware name for QCA6174
* mediatek: move MT8173 VPU FW to subfolder
* linux-firmware: Update firmware file for Intel Bluetooth AX201
* qca: Add firmware files for BT chip wcn3991.
* nvidia: add TU116/117 signed firmware
* drm/amdgpu: update to latest 19.50 firmware for raven
* mediatek: update MT8173 VPU firmware to v1.1.4

==== kio-extras5 ====
Version update (19.12.2 -> 19.12.3)
Subpackages: libkioarchive5

- Update to 19.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.3
- Too many changes since 19.12.2, only listing bugfixes:
* smb: enable anonymous and domain extra field in authinfo (kde#327484)
* smb: disable mode bits getting forwarded to KIO (kde#414482)
* smb: map ECONNABORTED to ERR_CONNECTION_BROKEN (kde#415436)
* smb: install smb as both smb:// and cifs:// (kde#327295)
* smb: do not map uid and gid (kde#212801)
* smb: fix free space calculation (kde#298801)
* smb: support more advanced hidden file flag (kde#307353)
* smb: call smb_cutime on the correct url to actually set mtime properly
(kde#356651)
* smb: retain atime properly (kde#410624)

==== konsole ====
Version update (19.12.2 -> 19.12.3)
Subpackages: konsole-part

- Update to 19.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.3
- No code change since 19.12.2

==== kwalletmanager5 ====
Version update (19.12.2 -> 19.12.3)

- Update to 19.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.3
- No code change since 19.12.2

==== libcontainers-common ====
Version update (20191211 -> 20200306)

- New snaphot (bsc#1165917)
- Update to image 5.2.1
* Add documentation about rewriting docker.io registries
* Add registries warning to registries.conf
- Update to libpod 1.8.0
* Fixed some spelling errors in oci-hooks documentations
* include containers-mounts.conf(5) man-page into the package
- Update to storage 1.16.1
* Add `rootless_storage_path` directive to storage.conf
* Add better documentation for the mount_program in overlay driver

==== libinput ====
Version update (1.15.2 -> 1.15.3)

- Update to release 1.15.3
* Restrict slot count code to ALPS devices only due to
side effects on other devices.

==== libnma ====
Version update (1.8.26 -> 1.8.28)
Subpackages: libnma0 typelib-1_0-NMA-1_0

- Update to version 1.8.28:
+ Turned the wireless-security library to a public API.
+ "org.gnome.nm-applet.gschema.xml" is now part of libnma.
Previously, on distributions like Fedora it was packaged as
part of nm-connection-editor package. But the schema is used by
wireless-security library, gnome-control-center and
nm-a/nm-c-e.
+ Clear key/password input fields when selecting a different
certificate in NMACertChooser.
+ Generate vapi files.
- Add pkgconfig(vapigen) BuildRequires: New dependency.
- Drop nma-data Requires: No longer needed. Add nma-data and
libnma-data Provides and Obsoletes, make upgrades problemfree
for our end-users.

==== libselinux ====
Version update (2.9 -> 3.0)
Subpackages: libselinux1 selinux-tools

- Update to version 3.0
* Ignore the stem when looking up all matches in file context
* Save digest of all partial matches for directory
* Use Python distutils to install SELinux python bindings
* ensure that digest_len is not zero
* fix string conversion of unknown perms
* mark all exported function "extern"
Dropped Use-Python-distutils-to-install-SELinux.patch, included
upstream

==== libselinux-bindings ====
Version update (2.9 -> 3.0)

- Update to version 3.0
* Ignore the stem when looking up all matches in file context
* Save digest of all partial matches for directory
* Use Python distutils to install SELinux python bindings
* ensure that digest_len is not zero
* fix string conversion of unknown perms
* mark all exported function "extern"

==== libsemanage ====
Version update (2.9 -> 3.0)

- Update to version 3.0
* Add support for DCCP and SCTP protocols
* include internal header to use the hidden function prototypes
* mark all exported function "extern"
* optionally optimize policy on rebuild
Refreshed suse_path.patch

==== libsepol ====
Version update (2.9 -> 3.0)

- Update to version 3.0
* cil: Allow validatetrans rules to be resolved
* cil: Report disabling an optional block only at high verbose levels
* cil: do not dereference perm_value_to_cil when it has not been allocated
* cil: fix mlsconstrain segfault
* Further improve binary policy optimization
* Make an unknown permission an error in CIL
* Remove cil_mem_error_handler() function pointer
* Use LIBSEPOL_3.0 and fix sepol_policydb_optimize symbol mapping
* Add a function to optimize kernel policy
* Add ebitmap_for_each_set_bit macro
Dropped fnocommon.patch as it's included upstream

==== open-vm-tools ====
Version update (11.0.0 -> 11.0.5)
Subpackages: libvmtools0

- Simplified the conditional around systemd_ordering to just use
suse_version >= 1500.
- Update to 11.0.5 (build 15389592) (boo#1165955)
+ DNS server is reported incorrectly as '127.0.0.53' when using
systemd-resolved. DNS server is reported incorrectly in GuestInfo as
'127.0.0.53' , when the OS uses systemd-resolved. This issue is fixed
in this release.
- Conditionalized the use of systemd_ordering. Use systemd_ordering
for factory, openSUSE >= 15, and SLE >= 15. Use systemd_requires
for older openSUSE and SLE releases.
- Conditionalize out the use of %license COPYING for SLE 12 SP2 and older.
- Added patches
+ gcc10-warning.patch (boo#1160408)
+ diskinfo-debug-logging-1162435.patch (boo#1162435 and bsc#1162119)
- Changed g_warning to g_debug
+ app_info_plugin.patch (boo#1165955)
- Drop unnecessary patch:
- fix-leaks-Aliases-MappedAliases.patch

==== patterns-base ====
Subpackages: patterns-base-base patterns-base-minimal_base patterns-base-x11

- drop telnet from enhanced_base recommendations
- Fix basic_desktop upgrade path for SLE-15 SP2 and later
- Put transactional_base in alphabetical order
- Fix SLE bug in generation of txt files for basic_desktop

==== perl-TimeDate ====
Version update (2.31 -> 2.32)

- updated to 2.32
see /usr/share/doc/packages/perl-TimeDate/ChangeLog
2.32 -- Wed Mar 04 14:41:00 MT 2020
* Fix t/date.t to run on leap years [arc]

==== policycoreutils ====
Version update (2.9 -> 3.0)
Subpackages: python3-policycoreutils

- Dropped Recommends: for %{name}-lang and %{name}-devel. Not
allowed by openSUSE guidelines
- Update to version 3.0
* fixfiles: Fix "verify" option
* fixfiles: Fix [-B] [-F] onboot
* fixfiles: Force full relabel when SELinux is disabled
* semodule: Enable CIL logging
* semanage: Add support for DCCP and SCTP protocols
* semanage: Do not use default s0 range in "semanage login -a"
* semanage: Document DCCP and SCTP support
* semanage: Improve handling of "permissive" statements
* semanage: fix moduleRecords.customized()
Refreshed chcat_join.patch
- Ship working pam config for newrole (bsc#1163020)
- Recommend policycoreutils-devel to have perm_map file available
- Package perm_map as it's used by audit2* tools

==== python-semanage ====
Version update (2.9 -> 3.0)

- Update to version 3.0
* Add support for DCCP and SCTP protocols
* include internal header to use the hidden function prototypes
* mark all exported function "extern"
* optionally optimize policy on rebuild
Refreshed suse_path.patch

==== restorecond ====
Version update (2.9 -> 3.0)

- Update to version 3.0
* Do not link against libpcre
* Fix redundant console log output error
* Use /run instead of /var/run
Dropped r_opts_global.patch

==== sddm ====
Subpackages: sddm-branding-openSUSE

- Don't add sddm to the video group, it's not necessary (see later
comments on boo#1165987)
- Add user sddm to group video to allow e.g. to use devices for
Nvidia X server (boo#1165987)
- Add (pre)requires for systemd macros, video group, the getent
(currently in glibc), and the groupadd (currently in shadow)

==== tracker ====
Subpackages: libtracker-common-2_0 libtracker-control-2_0-0
libtracker-miner-2_0-0 libtracker-sparql-2_0-0

- Add tracker-fix-segfault-in-writeback.patch: Check if argument is
NULL before using it and dispose connection and data_manager
before shutting down writeback and events to prevent segmentation
fault (bsc#1165357, glgo#GNOME/tracker!192).

==== transactional-update ====
Version update (2.20.2 -> 2.20.3)
Subpackages: transactional-update-zypp-config

- Update to version 2.20.3
- Reintroduce compatibility with RPM < 4.15 for inclusion in
SLE / Leap 15.2
- Prepare for removal of /var/lib/alternatives [jsc#SLE-9101]


--
To unsubscribe, e-mail: opensuse-kubic+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-kubic+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages