Mailinglist Archive: opensuse-kubic (68 mails)

< Previous Next >
[opensuse-kubic] New MicroOS snapshot 20200301 released!
  • From: Richard Brown <rbrown@xxxxxxx>
  • Date: Tue, 03 Mar 2020 14:04:47 +0000
  • Message-id: <158324428755.11613.17801414146581304159@go-agent-stagingbot-4>

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=microos&groupid=1&version=Tumbleweed&build=20200301
https://bugzilla.opensuse.org/buglist.cgi?product=openSUSE%20Tumbleweed&component=MicroOS&query_format=advanced&resolution=---

Please do not reply to this email to report issues, rather file a bug on
bugzilla.opensuse.org.
For more information on filing bugs please see
https://en.opensuse.org/openSUSE:Submitting_bug_reports
Packages changed:
cairo
libyui (3.9.2 -> 3.9.3)
libyui-qt (2.52.1 -> 2.52.2)
openssh
openssl-1_1
pam
polkit-default-privs (13.2+20200121.bfca858 -> 1550+20200213.f716f0a)
yast2 (4.2.61 -> 4.2.67)

=== Details ===

==== cairo ====
Subpackages: libcairo-gobject2 libcairo2

- Add an upstream bug fix
+ cairo-pdf-add-missing-flush.patch: Fixes PDF generation
see https://gitlab.freedesktop.org/cairo/cairo/issues/342

==== libyui ====
Version update (3.9.2 -> 3.9.3)

- Removed obsolete old RPM group tags (bsc#1163594)
- 3.9.3

==== libyui-qt ====
Version update (2.52.1 -> 2.52.2)

- Added missing gettext init (bsc#1163586)
- 2.52.2

==== openssh ====

- Don't recommend xauth to avoid pulling in X.

==== openssl-1_1 ====
Subpackages: libopenssl1_1

- Run FIPS DRBG selftests against the crypto/rand DRBG implementation
(bsc#1164557)
* add openssl-fips_selftest_upstream_drbg.patch

==== pam ====

- Recommend login.defs only (no hard requirement)

==== polkit-default-privs ====
Version update (13.2+20200121.bfca858 -> 1550+20200213.f716f0a)

- Going back to old versioning scheme as only %suse_version doesn't
carry enough information. Keeping the git hash would be enough,
but with that we can't ensure that versions increase. So we keep
also the timestamp and prefix it with the current %suse_version
- Change the package version to match %suse_version. The current
versioning was obviously based on this at one time. Dropping date
and git commit information since it's meaningless.
- Removed author information from the description
- Removed conditional Requires: for libmozjs185-1_0 for old
distributions
- Update to version 13.2+20200213.f716f0a:
* Revert "whitelist lutris (bsc#1161650)"
- Update to version 13.2+20200206.331ac1d:
* whitelist lutris (bsc#1161650)

==== yast2 ====
Version update (4.2.61 -> 4.2.67)

- Updated docu for SysctlConfig class (bsc#1151649).
- Creating an own Augeas instance for each parsed sysctl file
(bsc#1151649).
- 4.2.67
- SysctlConfig class: Handle sysctl entries in different
directories (bsc#1151649).
- 4.2.66
- Fixed user-visible messages (bsc#1084015)
- 4.2.65
- Show on WSL only WSL capable modules in control center
(bsc#1162650)
- 4.2.64
- Add new widgets CWM::ProgressBar and CWM::DynamicProgressBar.
- Needed for bsc#1135366.
- 4.2.63
- Do not crash when the "software/base_products" is not defined
in the control.xml (bsc#1161956)
- 4.2.62


--
To unsubscribe, e-mail: opensuse-kubic+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-kubic+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages