Mailinglist Archive: opensuse-kernel (19 mails)

< Previous Next >
[opensuse-kernel] kernel-devel conflicts on update from 4.14.12-1.x to 4.14.12-1.8
See
https://forums.opensuse.org/showthread.php/529126-Zypper-dup-failure-file-conflict-loop.
Suddenly zypper dup started to complain about file conflicts in
kernel-devel. Now we know it is impossible to multiversion two
rebuilds of the same RPM, but zypper has explicit workaround for
kernel-default and kernel-default-devel. Has something changed in
kernel packaging recently? Or is it zypper?

localhost:~ # zypper in -D kernel-default kernel-default-devel kernel-devel
Loading repository data...
Reading installed packages...
Resolving package dependencies...

The following 3 NEW packages are going to be installed:
kernel-default-4.14.12-1.8 kernel-default-devel-4.14.12-1.8
kernel-devel-4.14.12-1.8

The following 2 packages are going to be REMOVED:
kernel-default-4.14.12-1.4 kernel-default-devel-4.14.12-1.4

3 new packages to install, 2 to remove.
Overall download size: 75.5 MiB. Already cached: 0 B. After the
operation, additional 56.5 MiB will

Continue? [y/n/...? shows all options] (y): n
--
To unsubscribe, e-mail: opensuse-kernel+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-kernel+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups