Mailinglist Archive: opensuse-kde (114 mails)

< Previous Next >
[opensuse-kde] FYI: 13.2 and 42.1 support will be dropped in most KDE: repositories, other reorganizations
  • From: Luca Beltrame <lbeltrame@xxxxxxx>
  • Date: Wed, 08 Feb 2017 07:11:25 +0100
  • Message-id: <7705955.GtpDStj8hO@leon>
Hello,

in an effort to save build power and reorganize repositories where it makes
sense, we're removing support for 13.2 in the KDE: repositories. This is due
to the fact that 13.2 is now EOL'd and the base system is so old that it's
difficult to get new dependencies there.

For a similar reason we're removing support for Leap 42.1 from
KDE:Applications and KDE:Frameworks5 (and the :Unstable equivalents). The same
caveats apply there. 42.1 users will still be able to use the LTS variants of
Plasma and Frameworks at KDE:Frameworks5:LTS.

Support for 42.1 will remain in KDE:Extra, because the dependencies are less
strict there.

Lastly, KDE:Applications for Leap 42.2 will be adjusted in a way that it will
*require* KDE:Frameworks5 to be present. The reasoning is that otherwise it
will be impossible to build some parts of the stack (PIM in particular) with
the 42.2 base.

These changes will go into effect this weekend.

--
Luca Beltrame - KDE Forums team
GPG key ID: A29D259B
< Previous Next >