Mailinglist Archive: opensuse-kde (58 mails)

< Previous Next >
Re: [opensuse-kde] plasma5 on Leap or Tumbleweed in qemu/kvm/libvirt - success stories anyone?
  • From: "C. Brouerius van Nidek" <cbroueriusvannidek@xxxxxxxxx>
  • Date: Mon, 23 Nov 2015 08:52:47 +0700
  • Message-id: <11057142.zDGCqqDef0@dhcppc1>
On Sunday, November 22, 2015 04:47:00 PM Luca Beltrame wrote:
In data domenica 22 novembre 2015 15:44:21 CET, Oliver Kurz ha scritto:
I am trying to run openSUSE+plasma5 in a virtual machine driven by
qemu/kvm
with or without libvirt. So far, I did not have any success.

IIRC, qemu/kvm doesn't offer OpenGL, and Plasma 5 requires OpenGL 2 to work.

You may want to try and enable software rendering by putting a script in
~/.config/plasma-workspace/env:

#!/bin/sh

export QT_XCB_FORCE_SOFTWARE_OPENGL=1
export LIBGL_ALWAYS_SOFTWARE="true"

Interesting problem for both Leap and Tumbleweed.
My questions are, is there an easy way to find out:
1) if a "software rendering" is necessary, without going into the details of
the video card.
2) if "software rendering" really works after enabling it with the above
script?

Regards,
Constant

--
Linux User 183145 using KDE4 Tumbleweed on a Pentium IV ,
powered by openSUSE 20151118 (x86_64) Kernel: 4.3.0-2-default
KDE Development Platform: 4.14.12
08:36am up 14:48, 3 users, load average: 0.44, 0.57, 0.66

--
To unsubscribe, e-mail: opensuse-kde+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-kde+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups