Mailinglist Archive: opensuse-kde (310 mails)

< Previous Next >
Re: [opensuse-kde] KR49 linked libraries
On Monday 17 Sep 2012 23:24:01 Will Stephenson wrote:
On Monday 17 Sep 2012 23:11:02 Nico Kruber wrote:
KR49 contains some links to several libraries of other packages, e.g.
llvm.
These libs are needed for some packages to build for distros offering a
too- old version of them.

They are obviously disabled for openSUSE:Factory since there the newest
version should already exist. However, imho most of these could be
disabled
for at least 12.2, too since the version there is recent-enough.

Should we disable builds there or do we really need the most recent
version? - disabling builds would reduce the number of builds if these
libs change - enabling them would maybe fix some bugs

Yes, disable them if recent enough to build. They are probably a hangover
from before 12.2 was split.

There is one discrepancy for published lib-packages though:

if I disable their build in 12.2, the 12.1 repo will have newer libs than 12.2

packages that are only required to build though can get publish disabled and
are safe...
I suppose this applies only to the following packages though:
- cmake
- obs-service-format_spec_file

Nico
--
To unsubscribe, e-mail: opensuse-kde+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-kde+owner@xxxxxxxxxxxx

< Previous Next >