Mailinglist Archive: opensuse-kde (180 mails)

< Previous Next >
Re: [opensuse-kde] %kde4_runtime_requires also restricting kdebase4-runtime < 4.3.60 ?
  • From: Cristian Morales Vega <cmorve69@xxxxxxxx>
  • Date: Wed, 25 Nov 2009 17:13:26 +0100
  • Message-id: <8235e6f40911250813q1eb8cacak3ddddedc195693f7@xxxxxxxxxxxxxx>
2009/11/25 Lubos Lunak <l.lunak@xxxxxxx>:

 Hello,

 could somebody please explain to me the reason why we not only make all our
KDE apps require a minimal kdebase4-runtime version but also not allow a
higher minor version? This essentially breaks backwards compatibility,
kdelibs4-4.4.0 is backwards compatible with kdelibs4-4.3.0, but KDE apps
built against it can be used anyway, since we hardcode a requirement on
kdebase4-runtime. Morever that requirement seems to be completely unnecessary
to me, as it's just against the idea of KDE being backwards compatible with a
major version.

 So, why do we do that? Otherwise I will remove the restriction.

Wasn't this explained at
http://lists.opensuse.org/opensuse-kde/2009-06/msg00146.html?
--
To unsubscribe, e-mail: opensuse-kde+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-kde+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References